summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/debianutils
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/debianutils')
-rw-r--r--meta/recipes-support/debianutils/debianutils_4.11.2.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.11.2.bb b/meta/recipes-support/debianutils/debianutils_4.11.2.bb
index 1aedd8e6f3..231666c4dc 100644
--- a/meta/recipes-support/debianutils/debianutils_4.11.2.bb
+++ b/meta/recipes-support/debianutils/debianutils_4.11.2.bb
@@ -18,11 +18,11 @@ SRC_URI[sha256sum] = "3b680e81709b740387335fac8f8806d71611dcf60874e1a792e862e48a
18inherit autotools update-alternatives 18inherit autotools update-alternatives
19 19
20S = "${WORKDIR}/debianutils" 20S = "${WORKDIR}/debianutils"
21do_configure_prepend() { 21do_configure:prepend() {
22 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am 22 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
23} 23}
24 24
25do_install_append() { 25do_install:append() {
26 if [ "${base_bindir}" != "${bindir}" ]; then 26 if [ "${base_bindir}" != "${bindir}" ]; then
27 # Debian places some utils into ${base_bindir} as does busybox 27 # Debian places some utils into ${base_bindir} as does busybox
28 install -d ${D}${base_bindir} 28 install -d ${D}${base_bindir}
@@ -35,18 +35,18 @@ do_install_append() {
35# Note that we package the update-alternatives name. 35# Note that we package the update-alternatives name.
36# 36#
37PACKAGES =+ "${PN}-run-parts" 37PACKAGES =+ "${PN}-run-parts"
38FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils" 38FILES:${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
39 39
40RDEPENDS_${PN} += "${PN}-run-parts" 40RDEPENDS:${PN} += "${PN}-run-parts"
41RDEPENDS_${PN}_class-native = "" 41RDEPENDS:${PN}:class-native = ""
42 42
43ALTERNATIVE_PRIORITY = "30" 43ALTERNATIVE_PRIORITY = "30"
44ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which" 44ALTERNATIVE:${PN} = "add-shell installkernel remove-shell savelog tempfile which"
45 45
46ALTERNATIVE_PRIORITY_${PN}-run-parts = "60" 46ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
47ALTERNATIVE_${PN}-run-parts = "run-parts" 47ALTERNATIVE:${PN}-run-parts = "run-parts"
48 48
49ALTERNATIVE_${PN}-doc = "which.1" 49ALTERNATIVE:${PN}-doc = "which.1"
50ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1" 50ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
51 51
52ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell" 52ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell"