diff options
Diffstat (limited to 'meta/recipes-support/debianutils/debianutils_4.5.1.bb')
-rw-r--r-- | meta/recipes-support/debianutils/debianutils_4.5.1.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.5.1.bb b/meta/recipes-support/debianutils/debianutils_4.5.1.bb new file mode 100644 index 0000000000..9e5dd702f8 --- /dev/null +++ b/meta/recipes-support/debianutils/debianutils_4.5.1.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | SUMMARY = "Miscellaneous utilities specific to Debian" | ||
2 | SECTION = "base" | ||
3 | LICENSE = "GPLv2 & SMAIL_GPL" | ||
4 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=f01a5203d50512fc4830b4332b696a9f" | ||
5 | |||
6 | SRC_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/${BPN}_${PV}.tar.xz" | ||
7 | |||
8 | SRC_URI[md5sum] = "487524518cd5833a6a4f7007b5d1bd5b" | ||
9 | SRC_URI[sha256sum] = "a531c23e0105fe01cfa928457a8343a1e947e2621b3cd4d05f4e9656020c63b7" | ||
10 | |||
11 | S = "${WORKDIR}/${BPN}" | ||
12 | |||
13 | inherit autotools update-alternatives | ||
14 | |||
15 | do_configure_prepend() { | ||
16 | sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am | ||
17 | } | ||
18 | |||
19 | do_install_append() { | ||
20 | if [ "${base_bindir}" != "${bindir}" ]; then | ||
21 | # Debian places some utils into ${base_bindir} as does busybox | ||
22 | install -d ${D}${base_bindir} | ||
23 | for app in run-parts tempfile; do | ||
24 | mv ${D}${bindir}/$app ${D}${base_bindir}/$app | ||
25 | done | ||
26 | fi | ||
27 | } | ||
28 | |||
29 | ALTERNATIVE_PRIORITY="100" | ||
30 | ALTERNATIVE_${PN} = "add-shell installkernel remove-shell run-parts savelog tempfile which" | ||
31 | |||
32 | ALTERNATIVE_LINK_NAME[add-shell]="${sbindir}/add-shell" | ||
33 | ALTERNATIVE_LINK_NAME[installkernel]="${sbindir}/installkernel" | ||
34 | ALTERNATIVE_LINK_NAME[remove-shell]="${sbindir}/remove-shell" | ||
35 | ALTERNATIVE_LINK_NAME[run-parts]="${base_bindir}/run-parts" | ||
36 | ALTERNATIVE_LINK_NAME[savelog]="${bindir}/savelog" | ||
37 | ALTERNATIVE_LINK_NAME[tempfile]="${base_bindir}/tempfile" | ||
38 | ALTERNATIVE_LINK_NAME[which]="${bindir}/which" | ||