summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_6.0.35.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/db/db_6.0.35.bb')
-rw-r--r--meta/recipes-support/db/db_6.0.35.bb122
1 files changed, 122 insertions, 0 deletions
diff --git a/meta/recipes-support/db/db_6.0.35.bb b/meta/recipes-support/db/db_6.0.35.bb
new file mode 100644
index 0000000000..32afbe82d8
--- /dev/null
+++ b/meta/recipes-support/db/db_6.0.35.bb
@@ -0,0 +1,122 @@
1# Version 6 of the Berkeley DB from Oracle (formerly Sleepycat)
2#
3# At present this package only installs the DB code
4# itself (shared libraries, .a in the dev package),
5# documentation and headers.
6#
7# The headers have the same names as those as v3
8# of the DB, only one version can be used *for dev*
9# at once - DB3 and DB6 can both be installed on the
10# same system at the same time if really necessary.
11SECTION = "libs"
12SUMMARY = "Berkeley Database v6"
13HOMEPAGE = "http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html"
14LICENSE = "AGPL-3.0"
15VIRTUAL_NAME ?= "virtual/db"
16RCONFLICTS_${PN} = "db3"
17
18PR = "r1"
19
20# Note, when upgraded to 6.1.x, a patch in RPM will need to be removed to activate db 6.1 support.
21SRC_URI = "http://distfiles.gentoo.org/distfiles/db-${PV}.tar.gz \
22 file://arm-thumb-mutex_db5.patch \
23 file://fix-parallel-build.patch \
24 file://Makefile-let-libso_target-depend-on-bt_rec.patch \
25 file://Makefile-let-libdb-6.0.la-depend-os_map.l.patch \
26 "
27
28SRC_URI[md5sum] = "c65a4d3e930a116abaaf69edfc697f25"
29SRC_URI[sha256sum] = "24421affa8ae436fe427ae4f5f2d1634da83d3d55a5ad6354a98eeedb825de55"
30
31# Exclude NC versions which lack AES encryption
32UPSTREAM_CHECK_REGEX = "db-(?P<pver>\d+\.\d+(\.\d+)?).tar"
33UPSTREAM_CHECK_URI = "http://www.oracle.com/technetwork/products/berkeleydb/downloads/index-082944.html"
34
35LIC_FILES_CHKSUM = "file://LICENSE;md5=1ec8b0b17cc31513fe35ab10716f8490"
36
37# Put virtual/db in any appropriate provider of a
38# relational database, use it as a dependency in
39# place of a specific db and use:
40#
41# PREFERRED_PROVIDER_virtual/db
42#
43# to select the correct db in the build (distro) .conf
44PROVIDES += "${VIRTUAL_NAME}"
45
46inherit autotools
47
48# The executables go in a separate package - typically there
49# is no need to install these unless doing real database
50# management on the system.
51inherit lib_package
52
53PACKAGES =+ "${PN}-cxx"
54FILES_${PN}-cxx = "${libdir}/*cxx*so"
55
56# The dev package has the .so link (as in db3) and the .a's -
57# it is therefore incompatible (cannot be installed at the
58# same time) as the db3 package
59# sort out the .so since they do version prior to the .so
60SOLIBS = "-6*.so"
61FILES_SOLIBSDEV = "${libdir}/libdb.so ${libdir}/libdb_cxx.so"
62
63#configuration - set in local.conf to override
64# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
65DB6_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-verify --disable-compat185 --disable-sql"
66
67EXTRA_OECONF = "${DB6_CONFIG} --enable-shared --enable-cxx --with-sysroot"
68
69# Cancel the site stuff - it's set for db3 and destroys the configure.
70CONFIG_SITE = ""
71
72AUTOTOOLS_SCRIPT_PATH = "${S}/dist"
73
74do_configure() {
75 cd ${B}
76 gnu-configize --force ${AUTOTOOLS_SCRIPT_PATH}
77 oe_runconf
78}
79
80# Override the MUTEX setting here, the POSIX library is
81# the default - "POSIX/pthreads/library".
82# Don't ignore the nice SWP instruction on the ARM:
83# These enable the ARM assembler mutex code
84ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
85MUTEX = ""
86MUTEX_arm = "${ARM_MUTEX}"
87MUTEX_armeb = "${ARM_MUTEX}"
88EXTRA_OECONF += "${MUTEX}"
89EXTRA_OEMAKE_append_class-target = " LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
90EXTRA_OEMAKE += "STRIP=true"
91
92do_compile_prepend() {
93 # Stop libtool adding RPATHs
94 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/libtool
95}
96
97do_install_append() {
98 mkdir -p ${D}/${includedir}/db60
99 mv ${D}/${includedir}/db.h ${D}/${includedir}/db60/.
100 mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db60/.
101 ln -s db60/db.h ${D}/${includedir}/db.h
102 ln -s db60/db_cxx.h ${D}/${includedir}/db_cxx.h
103
104 # The docs end up in /usr/docs - not right.
105 if test -d "${D}/${prefix}/docs"
106 then
107 mkdir -p "${D}/${datadir}"
108 test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
109 mv "${D}/${prefix}/docs" "${D}/${docdir}"
110 fi
111
112 chown -R root:root ${D}
113}
114
115# libdb isn't versioned in the typical manner (libdb-6.0.so is the full library
116# name) so skip these checks.
117INSANE_SKIP_${PN} = "dev-so"
118INSANE_SKIP_${PN}-cxx = "dev-so"
119
120BBCLASSEXTEND = "native nativesdk"
121
122RECIPE_NO_UPDATE_REASON = "latest db does not work with RPM-5.x due to changes in locking semantics"