summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_5.3.28.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/db/db_5.3.28.bb')
-rw-r--r--meta/recipes-support/db/db_5.3.28.bb22
1 files changed, 10 insertions, 12 deletions
diff --git a/meta/recipes-support/db/db_5.3.28.bb b/meta/recipes-support/db/db_5.3.28.bb
index 318efcb61d..a99d5cea62 100644
--- a/meta/recipes-support/db/db_5.3.28.bb
+++ b/meta/recipes-support/db/db_5.3.28.bb
@@ -10,14 +10,14 @@
10# same system at the same time if really necessary. 10# same system at the same time if really necessary.
11SECTION = "libs" 11SECTION = "libs"
12SUMMARY = "Berkeley Database v5" 12SUMMARY = "Berkeley Database v5"
13DESCRIPTION = "Provides the foundational storage services for your application, no matter how demanding and unique your requirements may seem to be"
13HOMEPAGE = "https://www.oracle.com/database/technologies/related/berkeleydb.html" 14HOMEPAGE = "https://www.oracle.com/database/technologies/related/berkeleydb.html"
14LICENSE = "Sleepycat" 15LICENSE = "Sleepycat"
15RCONFLICTS_${PN} = "db3" 16RCONFLICTS:${PN} = "db3"
16 17
17CVE_PRODUCT = "oracle_berkeley_db" 18CVE_PRODUCT = "oracle_berkeley_db berkeley_db"
18CVE_VERSION = "11.2.${PV}" 19CVE_VERSION = "11.2.${PV}"
19 20
20PR = "r1"
21PE = "1" 21PE = "1"
22 22
23SRC_URI = "https://download.oracle.com/berkeley-db/db-${PV}.tar.gz" 23SRC_URI = "https://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
@@ -46,7 +46,7 @@ inherit autotools
46inherit lib_package 46inherit lib_package
47 47
48PACKAGES =+ "${PN}-cxx" 48PACKAGES =+ "${PN}-cxx"
49FILES_${PN}-cxx = "${libdir}/*cxx*so" 49FILES:${PN}-cxx = "${libdir}/*cxx*so"
50 50
51# The dev package has the .so link (as in db3) and the .a's - 51# The dev package has the .so link (as in db3) and the .a's -
52# it is therefore incompatible (cannot be installed at the 52# it is therefore incompatible (cannot be installed at the
@@ -65,8 +65,6 @@ PACKAGECONFIG ??= ""
65PACKAGECONFIG[verify] = "--enable-verify, --disable-verify" 65PACKAGECONFIG[verify] = "--enable-verify, --disable-verify"
66PACKAGECONFIG[dbm] = "--enable-dbm,--disable-dbm," 66PACKAGECONFIG[dbm] = "--enable-dbm,--disable-dbm,"
67 67
68EXTRA_OEMAKE += "LIBTOOL='./${HOST_SYS}-libtool'"
69
70EXTRA_AUTORECONF += "--exclude=autoheader -I ${S}/dist/aclocal -I${S}/dist/aclocal_java" 68EXTRA_AUTORECONF += "--exclude=autoheader -I ${S}/dist/aclocal -I${S}/dist/aclocal_java"
71AUTOTOOLS_SCRIPT_PATH = "${S}/dist" 69AUTOTOOLS_SCRIPT_PATH = "${S}/dist"
72 70
@@ -74,7 +72,7 @@ AUTOTOOLS_SCRIPT_PATH = "${S}/dist"
74# configure. 72# configure.
75CONFIG_SITE = "" 73CONFIG_SITE = ""
76 74
77oe_runconf_prepend() { 75oe_runconf:prepend() {
78 . ${S}/dist/RELEASE 76 . ${S}/dist/RELEASE
79 # Edit version information we couldn't pre-compute. 77 # Edit version information we couldn't pre-compute.
80 sed -i -e "s/__EDIT_DB_VERSION_FAMILY__/$DB_VERSION_FAMILY/g" \ 78 sed -i -e "s/__EDIT_DB_VERSION_FAMILY__/$DB_VERSION_FAMILY/g" \
@@ -88,12 +86,12 @@ oe_runconf_prepend() {
88 -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" ${S}/dist/configure 86 -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" ${S}/dist/configure
89} 87}
90 88
91do_compile_prepend() { 89do_compile:prepend() {
92 # Stop libtool adding RPATHs 90 # Stop libtool adding RPATHs
93 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/${HOST_SYS}-libtool 91 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/libtool
94} 92}
95 93
96do_install_append() { 94do_install:append() {
97 mkdir -p ${D}/${includedir}/db51 95 mkdir -p ${D}/${includedir}/db51
98 mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/. 96 mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/.
99 mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/. 97 mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/.
@@ -114,7 +112,7 @@ do_install_append() {
114 fi 112 fi
115} 113}
116 114
117INSANE_SKIP_${PN} = "dev-so" 115INSANE_SKIP:${PN} = "dev-so"
118INSANE_SKIP_${PN}-cxx = "dev-so" 116INSANE_SKIP:${PN}-cxx = "dev-so"
119 117
120BBCLASSEXTEND = "native nativesdk" 118BBCLASSEXTEND = "native nativesdk"