diff options
Diffstat (limited to 'meta/recipes-support/db/db_5.3.28.bb')
-rw-r--r-- | meta/recipes-support/db/db_5.3.28.bb | 115 |
1 files changed, 115 insertions, 0 deletions
diff --git a/meta/recipes-support/db/db_5.3.28.bb b/meta/recipes-support/db/db_5.3.28.bb new file mode 100644 index 0000000000..057c9d8425 --- /dev/null +++ b/meta/recipes-support/db/db_5.3.28.bb | |||
@@ -0,0 +1,115 @@ | |||
1 | # Version 5 of the Berkeley DB from Sleepycat | ||
2 | # | ||
3 | # At present this package only installs the DB code | ||
4 | # itself (shared libraries, .a in the dev package), | ||
5 | # documentation and headers. | ||
6 | # | ||
7 | # The headers have the same names as those as v3 | ||
8 | # of the DB, only one version can be used *for dev* | ||
9 | # at once - DB3 and DB5 can both be installed on the | ||
10 | # same system at the same time if really necessary. | ||
11 | SECTION = "libs" | ||
12 | SUMMARY = "Berkeley Database v5" | ||
13 | HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html" | ||
14 | LICENSE = "Sleepycat" | ||
15 | VIRTUAL_NAME ?= "virtual/db" | ||
16 | RCONFLICTS_${PN} = "db3" | ||
17 | |||
18 | SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz" | ||
19 | SRC_URI += "file://arm-thumb-mutex_db5.patch;patchdir=.. \ | ||
20 | file://fix-parallel-build.patch \ | ||
21 | " | ||
22 | |||
23 | SRC_URI[md5sum] = "b99454564d5b4479750567031d66fe24" | ||
24 | SRC_URI[sha256sum] = "e0a992d740709892e81f9d93f06daf305cf73fb81b545afe72478043172c3628" | ||
25 | |||
26 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=ed1158e31437f4f87cdd4ab2b8613955" | ||
27 | |||
28 | inherit autotools | ||
29 | |||
30 | # Put virtual/db in any appropriate provider of a | ||
31 | # relational database, use it as a dependency in | ||
32 | # place of a specific db and use: | ||
33 | # | ||
34 | # PREFERRED_PROVIDER_virtual/db | ||
35 | # | ||
36 | # to select the correct db in the build (distro) .conf | ||
37 | PROVIDES += "${VIRTUAL_NAME}" | ||
38 | |||
39 | # bitbake isn't quite clever enough to deal with sleepycat, | ||
40 | # the distribution sits in the expected directory, but all | ||
41 | # the builds must occur from a sub-directory. The following | ||
42 | # persuades bitbake to go to the right place | ||
43 | S = "${WORKDIR}/db-${PV}/dist" | ||
44 | B = "${WORKDIR}/db-${PV}/build_unix" | ||
45 | |||
46 | # The executables go in a separate package - typically there | ||
47 | # is no need to install these unless doing real database | ||
48 | # management on the system. | ||
49 | inherit lib_package | ||
50 | |||
51 | PACKAGES =+ "${PN}-cxx" | ||
52 | FILES_${PN}-cxx = "${libdir}/*cxx*so" | ||
53 | |||
54 | |||
55 | # The dev package has the .so link (as in db3) and the .a's - | ||
56 | # it is therefore incompatible (cannot be installed at the | ||
57 | # same time) as the db3 package | ||
58 | # sort out the .so since they do version prior to the .so | ||
59 | SOLIBS = "-5*.so" | ||
60 | FILES_SOLIBSDEV = "${libdir}/libdb.so ${libdir}/libdb_cxx.so" | ||
61 | |||
62 | #configuration - set in local.conf to override | ||
63 | # All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix) | ||
64 | DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-verify --disable-compat185 --disable-sql" | ||
65 | |||
66 | EXTRA_OECONF = "${DB5_CONFIG} --enable-shared --enable-cxx --with-sysroot" | ||
67 | |||
68 | # Override the MUTEX setting here, the POSIX library is | ||
69 | # the default - "POSIX/pthreads/library". | ||
70 | # Don't ignore the nice SWP instruction on the ARM: | ||
71 | # These enable the ARM assembler mutex code, this won't | ||
72 | # work with thumb compilation... | ||
73 | ARM_MUTEX = "--with-mutex=ARM/gcc-assembly" | ||
74 | MUTEX = "" | ||
75 | MUTEX_arm = "${ARM_MUTEX}" | ||
76 | MUTEX_armeb = "${ARM_MUTEX}" | ||
77 | EXTRA_OECONF += "${MUTEX}" | ||
78 | |||
79 | # Cancel the site stuff - it's set for db3 and destroys the | ||
80 | # configure. | ||
81 | CONFIG_SITE = "" | ||
82 | do_configure() { | ||
83 | gnu-configize --force ${S} | ||
84 | export STRIP="true" | ||
85 | oe_runconf | ||
86 | } | ||
87 | |||
88 | do_compile_prepend() { | ||
89 | sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' \ | ||
90 | ${B}/libtool | ||
91 | } | ||
92 | |||
93 | do_install_append() { | ||
94 | mkdir -p ${D}/${includedir}/db51 | ||
95 | mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/. | ||
96 | mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/. | ||
97 | ln -s db51/db.h ${D}/${includedir}/db.h | ||
98 | ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h | ||
99 | |||
100 | # The docs end up in /usr/docs - not right. | ||
101 | if test -d "${D}/${prefix}/docs" | ||
102 | then | ||
103 | mkdir -p "${D}/${datadir}" | ||
104 | test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}" | ||
105 | mv "${D}/${prefix}/docs" "${D}/${docdir}" | ||
106 | fi | ||
107 | |||
108 | chown -R root:root ${D} | ||
109 | } | ||
110 | |||
111 | INSANE_SKIP_${PN} = "dev-so" | ||
112 | INSANE_SKIP_${PN}-cxx = "dev-so" | ||
113 | |||
114 | BBCLASSEXTEND = "native nativesdk" | ||
115 | |||