summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_5.3.28.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/db/db_5.3.28.bb')
-rw-r--r--meta/recipes-support/db/db_5.3.28.bb116
1 files changed, 116 insertions, 0 deletions
diff --git a/meta/recipes-support/db/db_5.3.28.bb b/meta/recipes-support/db/db_5.3.28.bb
new file mode 100644
index 0000000000..e8b814e06b
--- /dev/null
+++ b/meta/recipes-support/db/db_5.3.28.bb
@@ -0,0 +1,116 @@
1# Version 5 of the Berkeley DB from Sleepycat
2#
3# At present this package only installs the DB code
4# itself (shared libraries, .a in the dev package),
5# documentation and headers.
6#
7# The headers have the same names as those as v3
8# of the DB, only one version can be used *for dev*
9# at once - DB3 and DB5 can both be installed on the
10# same system at the same time if really necessary.
11SECTION = "libs"
12SUMMARY = "Berkeley Database v5"
13HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
14LICENSE = "Sleepycat"
15VIRTUAL_NAME ?= "virtual/db"
16RCONFLICTS_${PN} = "db3"
17
18SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
19SRC_URI += "file://arm-thumb-mutex_db5.patch;patchdir=.. \
20 file://fix-parallel-build.patch \
21 "
22
23SRC_URI[md5sum] = "b99454564d5b4479750567031d66fe24"
24SRC_URI[sha256sum] = "e0a992d740709892e81f9d93f06daf305cf73fb81b545afe72478043172c3628"
25
26LIC_FILES_CHKSUM = "file://../LICENSE;md5=ed1158e31437f4f87cdd4ab2b8613955"
27
28inherit autotools
29
30# Put virtual/db in any appropriate provider of a
31# relational database, use it as a dependency in
32# place of a specific db and use:
33#
34# PREFERRED_PROVIDER_virtual/db
35#
36# to select the correct db in the build (distro) .conf
37PROVIDES += "${VIRTUAL_NAME}"
38
39# bitbake isn't quite clever enough to deal with sleepycat,
40# the distribution sits in the expected directory, but all
41# the builds must occur from a sub-directory. The following
42# persuades bitbake to go to the right place
43S = "${WORKDIR}/db-${PV}/dist"
44B = "${WORKDIR}/db-${PV}/build_unix"
45SPDX_S = "${WORKDIR}/db-${PV}"
46
47# The executables go in a separate package - typically there
48# is no need to install these unless doing real database
49# management on the system.
50inherit lib_package
51
52PACKAGES =+ "${PN}-cxx"
53FILES_${PN}-cxx = "${libdir}/*cxx*so"
54
55
56# The dev package has the .so link (as in db3) and the .a's -
57# it is therefore incompatible (cannot be installed at the
58# same time) as the db3 package
59# sort out the .so since they do version prior to the .so
60SOLIBS = "-5*.so"
61FILES_SOLIBSDEV = "${libdir}/libdb.so ${libdir}/libdb_cxx.so"
62
63#configuration - set in local.conf to override
64# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
65DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-verify --disable-compat185 --disable-sql"
66
67EXTRA_OECONF = "${DB5_CONFIG} --enable-shared --enable-cxx --with-sysroot"
68
69# Override the MUTEX setting here, the POSIX library is
70# the default - "POSIX/pthreads/library".
71# Don't ignore the nice SWP instruction on the ARM:
72# These enable the ARM assembler mutex code, this won't
73# work with thumb compilation...
74ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
75MUTEX = ""
76MUTEX_arm = "${ARM_MUTEX}"
77MUTEX_armeb = "${ARM_MUTEX}"
78EXTRA_OECONF += "${MUTEX}"
79
80# Cancel the site stuff - it's set for db3 and destroys the
81# configure.
82CONFIG_SITE = ""
83do_configure() {
84 gnu-configize --force ${S}
85 export STRIP="true"
86 oe_runconf
87}
88
89do_compile_prepend() {
90 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' \
91 ${B}/libtool
92}
93
94do_install_append() {
95 mkdir -p ${D}/${includedir}/db51
96 mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/.
97 mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/.
98 ln -s db51/db.h ${D}/${includedir}/db.h
99 ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h
100
101 # The docs end up in /usr/docs - not right.
102 if test -d "${D}/${prefix}/docs"
103 then
104 mkdir -p "${D}/${datadir}"
105 test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
106 mv "${D}/${prefix}/docs" "${D}/${docdir}"
107 fi
108
109 chown -R root:root ${D}
110}
111
112INSANE_SKIP_${PN} = "dev-so"
113INSANE_SKIP_${PN}-cxx = "dev-so"
114
115BBCLASSEXTEND = "native nativesdk"
116