summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_5.3.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/db/db_5.3.21.bb')
-rw-r--r--meta/recipes-support/db/db_5.3.21.bb108
1 files changed, 108 insertions, 0 deletions
diff --git a/meta/recipes-support/db/db_5.3.21.bb b/meta/recipes-support/db/db_5.3.21.bb
new file mode 100644
index 0000000000..23d6c4e369
--- /dev/null
+++ b/meta/recipes-support/db/db_5.3.21.bb
@@ -0,0 +1,108 @@
1# Version 5 of the Berkeley DB from Sleepycat
2#
3# At present this package only installs the DB code
4# itself (shared libraries, .a in the dev package),
5# documentation and headers.
6#
7# The headers have the same names as those as v3
8# of the DB, only one version can be used *for dev*
9# at once - DB3 and DB5 can both be installed on the
10# same system at the same time if really necessary.
11SECTION = "libs"
12DESCRIPTION = "Berkeley DB v5."
13HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
14LICENSE = "Sleepycat"
15VIRTUAL_NAME ?= "virtual/db"
16RCONFLICTS_${PN} = "db3"
17PR = "r0"
18
19SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
20SRC_URI += "file://arm-thumb-mutex_db5.patch;patchdir=.."
21
22SRC_URI[md5sum] = "3fda0b004acdaa6fa350bfc41a3b95ca"
23SRC_URI[sha256sum] = "ddd92a930317df92021054c03992392db9ea5cddba43bef8920d392a82114fb8"
24
25LIC_FILES_CHKSUM = "file://../LICENSE;md5=32aefa5a8e7318be1f657432cbe2e768"
26
27inherit autotools
28
29# Put virtual/db in any appropriate provider of a
30# relational database, use it as a dependency in
31# place of a specific db and use:
32#
33# PREFERRED_PROVIDER_virtual/db
34#
35# to select the correct db in the build (distro) .conf
36PROVIDES += "${VIRTUAL_NAME}"
37
38# bitbake isn't quite clever enough to deal with sleepycat,
39# the distribution sits in the expected directory, but all
40# the builds must occur from a sub-directory. The following
41# persuades bitbake to go to the right place
42S = "${WORKDIR}/db-${PV}/dist"
43B = "${WORKDIR}/db-${PV}/build_unix"
44
45# The executables go in a separate package - typically there
46# is no need to install these unless doing real database
47# management on the system.
48inherit lib_package
49
50# The dev package has the .so link (as in db3) and the .a's -
51# it is therefore incompatible (cannot be installed at the
52# same time) as the db3 package
53# sort out the .so since they do version prior to the .so
54SOLIBS = "-5*.so"
55FILES_SOLIBSDEV = "${libdir}/libdb.so"
56
57#configuration - set in local.conf to override
58# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
59DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-verify --disable-compat185 --disable-sql"
60
61EXTRA_OECONF = "${DB5_CONFIG}"
62
63# Override the MUTEX setting here, the POSIX library is
64# the default - "POSIX/pthreads/library".
65# Don't ignore the nice SWP instruction on the ARM:
66# These enable the ARM assembler mutex code, this won't
67# work with thumb compilation...
68ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
69MUTEX = ""
70MUTEX_arm = "${ARM_MUTEX}"
71MUTEX_armeb = "${ARM_MUTEX}"
72EXTRA_OECONF += "${MUTEX}"
73
74# Cancel the site stuff - it's set for db3 and destroys the
75# configure.
76CONFIG_SITE = ""
77do_configure() {
78 gnu-configize --force ${S}
79 export STRIP="true"
80 oe_runconf
81}
82
83do_install_append() {
84 mkdir -p ${D}/${includedir}/db51
85 #mv ${D}/${includedir}/db_185.h ${D}/${includedir}/db51/.
86 mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/.
87 mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/.
88 #mv ${D}/${includedir}/dbsql.h ${D}/${includedir}/db51/.
89 #ln -s db51/db_185.h ${D}/${includedir}/db_185.h
90 ln -s db51/db.h ${D}/${includedir}/db.h
91 ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h
92 #ln -s db51/dbsql.h ${D}/${includedir}/dbsql.h
93
94 # The docs end up in /usr/docs - not right.
95 if test -d "${D}/${prefix}/docs"
96 then
97 mkdir -p "${D}/${datadir}"
98 test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
99 mv "${D}/${prefix}/docs" "${D}/${docdir}"
100 fi
101
102 chown -R root:root ${D}
103}
104
105INSANE_SKIP_${PN} = "dev-so"
106
107BBCLASSEXTEND = "native nativesdk"
108