summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_5.3.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/db/db_5.3.15.bb')
-rw-r--r--meta/recipes-support/db/db_5.3.15.bb108
1 files changed, 108 insertions, 0 deletions
diff --git a/meta/recipes-support/db/db_5.3.15.bb b/meta/recipes-support/db/db_5.3.15.bb
new file mode 100644
index 0000000000..9d2bbe5e46
--- /dev/null
+++ b/meta/recipes-support/db/db_5.3.15.bb
@@ -0,0 +1,108 @@
1# Version 5 of the Berkeley DB from Sleepycat
2#
3# At present this package only installs the DB code
4# itself (shared libraries, .a in the dev package),
5# documentation and headers.
6#
7# The headers have the same names as those as v3
8# of the DB, only one version can be used *for dev*
9# at once - DB3 and DB5 can both be installed on the
10# same system at the same time if really necessary.
11SECTION = "libs"
12DESCRIPTION = "Berkeley DB v5."
13HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
14LICENSE = "Sleepycat"
15VIRTUAL_NAME ?= "virtual/db"
16CONFLICTS = "db3"
17PR = "r5"
18
19SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
20SRC_URI += "file://arm-thumb-mutex_db5.patch;patchdir=.."
21
22SRC_URI[md5sum] = "5493fb5f7cc3915887c836b096f18773"
23SRC_URI[sha256sum] = "4f4f7d548984dde3584fcda0e4f96901cb8bafb08033a7781aec64ef2ea1f579"
24
25LIC_FILES_CHKSUM = "file://../LICENSE;md5=12cc3ff983ed4ecc6cc091370ee4dbc3"
26
27inherit autotools
28
29# Put virtual/db in any appropriate provider of a
30# relational database, use it as a dependency in
31# place of a specific db and use:
32#
33# PREFERRED_PROVIDER_virtual/db
34#
35# to select the correct db in the build (distro) .conf
36PROVIDES += "${VIRTUAL_NAME}"
37
38# bitbake isn't quite clever enough to deal with sleepycat,
39# the distribution sits in the expected directory, but all
40# the builds must occur from a sub-directory. The following
41# persuades bitbake to go to the right place
42S = "${WORKDIR}/db-${PV}/dist"
43B = "${WORKDIR}/db-${PV}/build_unix"
44
45# The executables go in a separate package - typically there
46# is no need to install these unless doing real database
47# management on the system.
48PACKAGES += " ${PN}-bin"
49
50# Package contents
51FILES_${PN} = "${libdir}/libdb-5*so*"
52FILES_${PN}-bin = "${bindir}/*"
53# The dev package has the .so link (as in db3) and the .a's -
54# it is therefore incompatible (cannot be installed at the
55# same time) as the db3 package, allow the default packaging
56# to sort out ${libdir}
57
58#configuration - set in local.conf to override
59# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
60DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-statistics --disable-verify --disable-compat185 --disable-sql"
61
62EXTRA_OECONF = "${DB5_CONFIG}"
63
64# Override the MUTEX setting here, the POSIX library is
65# the default - "POSIX/pthreads/library".
66# Don't ignore the nice SWP instruction on the ARM:
67# These enable the ARM assembler mutex code, this won't
68# work with thumb compilation...
69ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
70MUTEX = ""
71MUTEX_arm = "${ARM_MUTEX}"
72MUTEX_armeb = "${ARM_MUTEX}"
73EXTRA_OECONF += "${MUTEX}"
74
75# Cancel the site stuff - it's set for db3 and destroys the
76# configure.
77CONFIG_SITE = ""
78do_configure() {
79 export STRIP="true"
80 oe_runconf
81}
82
83do_install_append() {
84 mkdir -p ${D}/${includedir}/db51
85 #mv ${D}/${includedir}/db_185.h ${D}/${includedir}/db51/.
86 mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/.
87 mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/.
88 #mv ${D}/${includedir}/dbsql.h ${D}/${includedir}/db51/.
89 #ln -s db51/db_185.h ${D}/${includedir}/db_185.h
90 ln -s db51/db.h ${D}/${includedir}/db.h
91 ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h
92 #ln -s db51/dbsql.h ${D}/${includedir}/dbsql.h
93
94 # The docs end up in /usr/docs - not right.
95 if test -d "${D}/${prefix}/docs"
96 then
97 mkdir -p "${D}/${datadir}"
98 test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
99 mv "${D}/${prefix}/docs" "${D}/${docdir}"
100 fi
101
102 chown -R root:root ${D}
103}
104
105INSANE_SKIP_${PN} = "dev-so"
106
107BBCLASSEXTEND = "native nativesdk"
108