summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_5.1.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/db/db_5.1.19.bb')
-rw-r--r--meta/recipes-support/db/db_5.1.19.bb104
1 files changed, 104 insertions, 0 deletions
diff --git a/meta/recipes-support/db/db_5.1.19.bb b/meta/recipes-support/db/db_5.1.19.bb
new file mode 100644
index 0000000000..919e532be1
--- /dev/null
+++ b/meta/recipes-support/db/db_5.1.19.bb
@@ -0,0 +1,104 @@
1# Version 5 of the Berkeley DB from Sleepycat
2#
3# At present this package only installs the DB code
4# itself (shared libraries, .a in the dev package),
5# documentation and headers.
6#
7# The headers have the same names as those as v3
8# of the DB, only one version can be used *for dev*
9# at once - DB3 and DB5 can both be installed on the
10# same system at the same time if really necessary.
11SECTION = "libs"
12DESCRIPTION = "Berkeley DB v5."
13HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
14LICENSE = "BSD Sleepycat"
15VIRTUAL_NAME ?= "virtual/db"
16CONFLICTS = "db3"
17PR = "r1"
18
19SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
20#SRC_URI_MD5 = "http://downloads.sleepycat.com/db-${PV}.tar.gz.md5"
21SRC_URI += "file://arm-thumb-mutex_db5.patch;patch=1"
22
23SRC_URI[md5sum] = "76fcbfeebfcd09ba0b4d96bfdf8d884d"
24SRC_URI[sha256sum] = "0194d4ca9266ba1a1c0bfbc233b18bfd05f63163453c81ebcdfdc7112d5ac850"
25
26LIC_FILES_CHKSUM = "file://../LICENSE;md5=86f9294f39f38ef9e89690bcd2320e7a"
27
28inherit autotools
29
30# Put virtual/db in any appropriate provider of a
31# relational database, use it as a dependency in
32# place of a specific db and use:
33#
34# PREFERRED_PROVIDER_virtual/db
35#
36# to select the correct db in the build (distro) .conf
37PROVIDES += "${VIRTUAL_NAME}"
38
39# bitbake isn't quite clever enough to deal with sleepycat,
40# the distribution sits in the expected directory, but all
41# the builds must occur from a sub-directory. The following
42# persuades bitbake to go to the right place
43S = "${WORKDIR}/db-${PV}/dist"
44B = "${WORKDIR}/db-${PV}/build_unix"
45
46# The executables go in a separate package - typically there
47# is no need to install these unless doing real database
48# management on the system.
49PACKAGES += " ${PN}-bin"
50
51# Package contents
52FILES_${PN} = "${libdir}/libdb-5*so*"
53FILES_${PN}-bin = "${bindir}/*"
54# The dev package has the .so link (as in db3) and the .a's -
55# it is therefore incompatible (cannot be installed at the
56# same time) as the db3 package
57FILES_${PN}-dev = "${includedir} ${libdir}/*"
58
59#configuration - set in local.conf to override
60# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
61DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-statistics --disable-verify --disable-compat185 --disable-sql"
62
63EXTRA_OECONF = "${DB5_CONFIG}"
64
65# Override the MUTEX setting here, the POSIX library is
66# the default - "POSIX/pthreads/library".
67# Don't ignore the nice SWP instruction on the ARM:
68# These enable the ARM assembler mutex code, this won't
69# work with thumb compilation...
70ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
71MUTEX = ""
72MUTEX_arm = "${ARM_MUTEX}"
73MUTEX_armeb = "${ARM_MUTEX}"
74EXTRA_OECONF += "${MUTEX}"
75
76# Cancel the site stuff - it's set for db3 and destroys the
77# configure.
78CONFIG_SITE = ""
79do_configure() {
80 oe_runconf
81}
82
83do_install_append() {
84 mkdir -p ${D}/${includedir}/db51
85 #mv ${D}/${includedir}/db_185.h ${D}/${includedir}/db51/.
86 mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/.
87 mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/.
88 #mv ${D}/${includedir}/dbsql.h ${D}/${includedir}/db51/.
89 #ln -s db51/db_185.h ${D}/${includedir}/db_185.h
90 ln -s db51/db.h ${D}/${includedir}/db.h
91 ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h
92 #ln -s db51/dbsql.h ${D}/${includedir}/dbsql.h
93
94 # The docs end up in /usr/docs - not right.
95 if test -d "${D}/${prefix}/docs"
96 then
97 mkdir -p "${D}/${datadir}"
98 test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
99 mv "${D}/${prefix}/docs" "${D}/${docdir}"
100 fi
101}
102
103BBCLASSEXTEND = "native nativesdk"
104