summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_4.3.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/db/db_4.3.29.bb')
-rw-r--r--meta/recipes-support/db/db_4.3.29.bb89
1 files changed, 89 insertions, 0 deletions
diff --git a/meta/recipes-support/db/db_4.3.29.bb b/meta/recipes-support/db/db_4.3.29.bb
new file mode 100644
index 0000000000..04a6680f07
--- /dev/null
+++ b/meta/recipes-support/db/db_4.3.29.bb
@@ -0,0 +1,89 @@
1# Has issues with eds
2DEFAULT_PREFERENCE = "-1"
3
4# Version 4 of the Berkeley DB from Sleepycat
5#
6# At present this package only installs the DB code
7# itself (shared libraries, .a in the dev package),
8# documentation and headers.
9#
10# The headers have the same names as those as v3
11# of the DB, only one version can be used *for dev*
12# at once - DB3 and DB4 can both be installed on the
13# same system at the same time if really necessary.
14SECTION = "libs"
15DESCRIPTION = "Berkeley DB v4."
16HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
17LICENSE = "BSD Sleepycat"
18VIRTUAL_NAME ?= "virtual/db"
19CONFLICTS = "db3"
20PR = "r8"
21
22SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
23#SRC_URI_MD5 = "http://downloads.sleepycat.com/db-${PV}.tar.gz.md5"
24SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
25
26inherit autotools
27
28# Put virtual/db in any appropriate provider of a
29# relational database, use it as a dependency in
30# place of a specific db and use:
31#
32# PREFERRED_PROVIDER_virtual/db
33#
34# to select the correct db in the build (distro) .conf
35PROVIDES += "${VIRTUAL_NAME}"
36
37# bitbake isn't quite clever enough to deal with sleepycat,
38# the distribution sits in the expected directory, but all
39# the builds must occur from a sub-directory. The following
40# persuades bitbake to go to the right place
41S = "${WORKDIR}/db-${PV}/dist"
42B = "${WORKDIR}/db-${PV}/build_unix"
43
44# The executables go in a separate package - typically there
45# is no need to install these unless doing real database
46# management on the system.
47PACKAGES += " ${PN}-bin"
48
49# Package contents
50FILES_${PN} = "${libdir}/libdb-4*so*"
51FILES_${PN}-bin = "${bindir}/*"
52# The dev package has the .so link (as in db3) and the .a's -
53# it is therefore incompatible (cannot be installed at the
54# same time) as the db3 package
55FILES_${PN}-dev = "${includedir} ${libdir}/*"
56
57#configuration - set in local.conf to override
58# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
59DB4_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-statistics --disable-verify --enable-compat185"
60
61EXTRA_OECONF = "${DB4_CONFIG}"
62
63# Override the MUTEX setting here, the POSIX library is
64# the default - "POSIX/pthreads/library".
65# Don't ignore the nice SWP instruction on the ARM:
66# These enable the ARM assembler mutex code, this won't
67# work with thumb compilation...
68ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
69MUTEX = ""
70MUTEX_arm = "${ARM_MUTEX}"
71MUTEX_armeb = "${ARM_MUTEX}"
72EXTRA_OECONF += "${MUTEX}"
73
74# Cancel the site stuff - it's set for db3 and destroys the
75# configure.
76CONFIG_SITE = ""
77do_configure() {
78 oe_runconf
79}
80
81do_install_append() {
82 # The docs end up in /usr/docs - not right.
83 if test -d "${D}/${prefix}/docs"
84 then
85 mkdir -p "${D}/${datadir}"
86 test ! -d "${D}/${docdir}" || rmdir "${D}/${docdir}"
87 mv "${D}/${prefix}/docs" "${D}/${docdir}"
88 fi
89}