summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.72.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.72.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.72.0.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.72.0.bb b/meta/recipes-support/curl/curl_7.72.0.bb
new file mode 100644
index 0000000000..e7f5492694
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.72.0.bb
@@ -0,0 +1,83 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=2e9fb35867314fe31c6a4977ef7dd531"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://0001-replace-krb5-config-with-pkg-config.patch \
10"
11
12SRC_URI[sha256sum] = "ad91970864102a59765e20ce16216efc9d6ad381471f7accceceab7d905703ef"
13
14CVE_PRODUCT = "curl libcurl"
15inherit autotools pkgconfig binconfig multilib_header
16
17PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} gnutls libidn proxy threaded-resolver verbose zlib"
18PACKAGECONFIG_class-native = "ipv6 proxy ssl threaded-resolver verbose zlib"
19PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl threaded-resolver verbose zlib"
20
21# 'ares' and 'threaded-resolver' are mutually exclusive
22PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares,,,threaded-resolver"
23PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
24PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual"
25PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
26PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
27PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
28PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
30PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
31PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
32PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
33PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
34PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
35PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
36PACKAGECONFIG[mqtt] = "--enable-mqtt,--disable-mqtt,"
37PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
38PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
39PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
40PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
41PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
42PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
43PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
44PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
45PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss"
46PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
47PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
48PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver,,,,ares"
49PACKAGECONFIG[verbose] = "--enable-verbose,--disable-verbose"
50PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
51
52EXTRA_OECONF = " \
53 --disable-libcurl-option \
54 --disable-ntlm-wb \
55 --enable-crypto-auth \
56 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
57 --without-libmetalink \
58 --without-libpsl \
59 --enable-debug \
60 --enable-optimize \
61 --disable-curldebug \
62"
63
64do_install_append_class-target() {
65 # cleanup buildpaths from curl-config
66 sed -i \
67 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
68 -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
69 -e 's|${DEBUG_PREFIX_MAP}||g' \
70 ${D}${bindir}/curl-config
71}
72
73PACKAGES =+ "lib${BPN}"
74
75FILES_lib${BPN} = "${libdir}/lib*.so.*"
76RRECOMMENDS_lib${BPN} += "ca-certificates"
77
78FILES_${PN} += "${datadir}/zsh"
79
80inherit multilib_script
81MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/curl-config"
82
83BBCLASSEXTEND = "native nativesdk"