summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.69.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.69.1.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.69.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.69.1.bb b/meta/recipes-support/curl/curl_7.69.1.bb
index c3d629108a..2f351d585a 100644
--- a/meta/recipes-support/curl/curl_7.69.1.bb
+++ b/meta/recipes-support/curl/curl_7.69.1.bb
@@ -1,4 +1,8 @@
1SUMMARY = "Command line tool and library for client-side URL transfers" 1SUMMARY = "Command line tool and library for client-side URL transfers"
2DESCRIPTION = "It uses URL syntax to transfer data to and from servers. \
3curl is a widely used because of its ability to be flexible and complete \
4complex tasks. For example, you can use curl for things like user authentication, \
5HTTP post, SSL connections, proxy support, FTP uploads, and more!"
2HOMEPAGE = "http://curl.haxx.se/" 6HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker" 7BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network" 8SECTION = "console/network"
@@ -13,6 +17,48 @@ SRC_URI = "https://curl.haxx.se/download/curl-${PV}.tar.bz2 \
13 file://CVE-2020-8284.patch \ 17 file://CVE-2020-8284.patch \
14 file://CVE-2020-8285.patch \ 18 file://CVE-2020-8285.patch \
15 file://CVE-2020-8286.patch \ 19 file://CVE-2020-8286.patch \
20 file://CVE-2021-22876.patch \
21 file://CVE-2021-22890.patch \
22 file://CVE-2021-22898.patch \
23 file://CVE-2021-22924.patch \
24 file://CVE-2021-22925.patch \
25 file://CVE-2021-22946-pre1.patch \
26 file://CVE-2021-22946.patch \
27 file://CVE-2021-22947.patch \
28 file://CVE-2022-27776.patch \
29 file://CVE-2022-27775.patch \
30 file://CVE-2022-22576.patch \
31 file://CVE-2022-27774-1.patch \
32 file://CVE-2022-27774-2.patch \
33 file://CVE-2022-27774-3.patch \
34 file://CVE-2022-27774-4.patch \
35 file://CVE-2022-27781.patch \
36 file://CVE-2022-27782-1.patch \
37 file://CVE-2022-27782-2.patch \
38 file://CVE-2022-32206.patch \
39 file://CVE-2022-32207.patch \
40 file://CVE-2022-32208.patch \
41 file://CVE-2022-35252.patch \
42 file://CVE-2022-32221.patch \
43 file://CVE-2022-35260.patch \
44 file://CVE-2022-43552.patch \
45 file://CVE-2023-23916.patch \
46 file://CVE-2023-27534-pre1.patch \
47 file://CVE-2023-27534.patch \
48 file://CVE-2023-27538.patch \
49 file://CVE-2023-27533.patch \
50 file://CVE-2023-27535-pre1.patch \
51 file://CVE-2023-27535.patch \
52 file://CVE-2023-27536.patch \
53 file://CVE-2023-28320.patch \
54 file://CVE-2023-28320-fol1.patch \
55 file://CVE-2023-32001.patch \
56 file://CVE-2023-38545.patch \
57 file://CVE-2023-38546.patch \
58 file://CVE-2023-28321.patch \
59 file://CVE-2023-28322.patch \
60 file://CVE-2023-46218.patch \
61 file://CVE-2024-2398.patch \
16" 62"
17 63
18SRC_URI[md5sum] = "ec5fc263f898a3dfef08e805f1ecca42" 64SRC_URI[md5sum] = "ec5fc263f898a3dfef08e805f1ecca42"
@@ -20,6 +66,15 @@ SRC_URI[sha256sum] = "2ff5e5bd507adf6aa88ff4bbafd4c7af464867ffb688be93b9930717a5
20 66
21# Curl has used many names over the years... 67# Curl has used many names over the years...
22CVE_PRODUCT = "haxx:curl haxx:libcurl curl:curl curl:libcurl libcurl:libcurl daniel_stenberg:curl" 68CVE_PRODUCT = "haxx:curl haxx:libcurl curl:curl curl:libcurl libcurl:libcurl daniel_stenberg:curl"
69CVE_CHECK_WHITELIST = "CVE-2021-22922 CVE-2021-22923 CVE-2021-22926 CVE-2021-22945"
70
71# As per link https://security-tracker.debian.org/tracker/CVE-2021-22897
72# and https://ubuntu.com/security/CVE-2021-22897
73# This CVE issue affects Windows only Hence whitelisting this CVE
74CVE_CHECK_WHITELIST += "CVE-2021-22897"
75
76# This CVE reports that apple had to upgrade curl because of other already reported CVEs
77CVE_CHECK_WHITELIST += "CVE-2023-42915"
23 78
24inherit autotools pkgconfig binconfig multilib_header 79inherit autotools pkgconfig binconfig multilib_header
25 80