summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.61.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.61.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.61.0.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.61.0.bb b/meta/recipes-support/curl/curl_7.61.0.bb
new file mode 100644
index 0000000000..a80f926e9b
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.61.0.bb
@@ -0,0 +1,71 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=8;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://0001-replace-krb5-config-with-pkg-config.patch \
10"
11
12SRC_URI[md5sum] = "31d0a9f48dc796a7db351898a1e5058a"
13SRC_URI[sha256sum] = "5f6f336921cf5b84de56afbd08dfb70adeef2303751ffb3e570c936c6d656c9c"
14
15CVE_PRODUCT = "libcurl"
16inherit autotools pkgconfig binconfig multilib_header
17
18PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} gnutls proxy threaded-resolver zlib"
19PACKAGECONFIG_class-native = "ipv6 proxy ssl threaded-resolver zlib"
20PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl threaded-resolver zlib"
21
22# 'ares' and 'threaded-resolver' are mutually exclusive
23PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares"
24PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
25PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
26PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
27PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
28PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
29PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
30PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
31PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
32PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
33PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
34PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
35PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
36PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
37PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
38PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
39PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
40PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
41PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
42PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
43PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
44PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
45PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver"
46PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
47
48EXTRA_OECONF = " \
49 --enable-crypto-auth \
50 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
51 --without-libmetalink \
52 --without-libpsl \
53"
54
55do_install_append_class-target() {
56 # cleanup buildpaths from curl-config
57 sed -i \
58 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
59 -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
60 -e 's|${DEBUG_PREFIX_MAP}||g' \
61 ${D}${bindir}/curl-config
62}
63
64PACKAGES =+ "lib${BPN}"
65
66FILES_lib${BPN} = "${libdir}/lib*.so.*"
67RRECOMMENDS_lib${BPN} += "ca-certificates"
68
69FILES_${PN} += "${datadir}/zsh"
70
71BBCLASSEXTEND = "native nativesdk"