diff options
Diffstat (limited to 'meta/recipes-support/curl/curl_7.58.0.bb')
-rw-r--r-- | meta/recipes-support/curl/curl_7.58.0.bb | 77 |
1 files changed, 77 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.58.0.bb b/meta/recipes-support/curl/curl_7.58.0.bb new file mode 100644 index 0000000000..5535a5609b --- /dev/null +++ b/meta/recipes-support/curl/curl_7.58.0.bb | |||
@@ -0,0 +1,77 @@ | |||
1 | SUMMARY = "Command line tool and library for client-side URL transfers" | ||
2 | HOMEPAGE = "http://curl.haxx.se/" | ||
3 | BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker" | ||
4 | SECTION = "console/network" | ||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;beginline=8;md5=3a34942f4ae3fbf1a303160714e664ac" | ||
7 | |||
8 | SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \ | ||
9 | file://0001-replace-krb5-config-with-pkg-config.patch \ | ||
10 | " | ||
11 | |||
12 | |||
13 | # curl likes to set -g0 in CFLAGS, so we stop it | ||
14 | # from mucking around with debug options | ||
15 | # | ||
16 | SRC_URI += " file://configure_ac.patch" | ||
17 | |||
18 | SRC_URI[md5sum] = "fa049f9f90c1ae473a2a7bcfa14de976" | ||
19 | SRC_URI[sha256sum] = "1cb081f97807c01e3ed747b6e1c9fee7a01cb10048f1cd0b5f56cfe0209de731" | ||
20 | |||
21 | CVE_PRODUCT = "libcurl" | ||
22 | inherit autotools pkgconfig binconfig multilib_header | ||
23 | |||
24 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} gnutls proxy threaded-resolver zlib" | ||
25 | PACKAGECONFIG_class-native = "ipv6 proxy ssl threaded-resolver zlib" | ||
26 | PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl threaded-resolver zlib" | ||
27 | |||
28 | # 'ares' and 'threaded-resolver' are mutually exclusive | ||
29 | PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares" | ||
30 | PACKAGECONFIG[dict] = "--enable-dict,--disable-dict," | ||
31 | PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls" | ||
32 | PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher," | ||
33 | PACKAGECONFIG[imap] = "--enable-imap,--disable-imap," | ||
34 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," | ||
35 | PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap," | ||
36 | PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps," | ||
37 | PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn" | ||
38 | PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2" | ||
39 | PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3," | ||
40 | PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy," | ||
41 | PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump" | ||
42 | PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp," | ||
43 | PACKAGECONFIG[smb] = "--enable-smb,--disable-smb," | ||
44 | PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp," | ||
45 | PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl" | ||
46 | PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet," | ||
47 | PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp," | ||
48 | PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver" | ||
49 | PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib" | ||
50 | PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5" | ||
51 | PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2" | ||
52 | |||
53 | EXTRA_OECONF = " \ | ||
54 | --enable-crypto-auth \ | ||
55 | --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \ | ||
56 | --without-libmetalink \ | ||
57 | --without-libpsl \ | ||
58 | " | ||
59 | |||
60 | |||
61 | do_install_append_class-target() { | ||
62 | # cleanup buildpaths from curl-config | ||
63 | sed -i \ | ||
64 | -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ | ||
65 | -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \ | ||
66 | -e 's|${DEBUG_PREFIX_MAP}||g' \ | ||
67 | ${D}${bindir}/curl-config | ||
68 | } | ||
69 | |||
70 | PACKAGES =+ "lib${BPN}" | ||
71 | |||
72 | FILES_lib${BPN} = "${libdir}/lib*.so.*" | ||
73 | RRECOMMENDS_lib${BPN} += "ca-certificates" | ||
74 | |||
75 | FILES_${PN} += "${datadir}/zsh" | ||
76 | |||
77 | BBCLASSEXTEND = "native nativesdk" | ||