summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.53.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.53.1.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.53.1.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.53.1.bb b/meta/recipes-support/curl/curl_7.53.1.bb
new file mode 100644
index 0000000000..9eb9720b6d
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.53.1.bb
@@ -0,0 +1,68 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=8;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2"
9
10# curl likes to set -g0 in CFLAGS, so we stop it
11# from mucking around with debug options
12#
13SRC_URI += " file://configure_ac.patch"
14
15SRC_URI[md5sum] = "fb1f03a142236840c1a77c035fa4c542"
16SRC_URI[sha256sum] = "1c7207c06d75e9136a944a2e0528337ce76f15b9ec9ae4bb30d703b59bf530e8"
17
18inherit autotools pkgconfig binconfig multilib_header
19
20PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)} gnutls proxy zlib"
21PACKAGECONFIG_class-native = "ipv6 proxy ssl zlib"
22PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl zlib"
23
24PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
25PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
26PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
27PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
28PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
29PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
30PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
31PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn"
32PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
33PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
34PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
35PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
36PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
37PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
38PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
39PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
40PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
41PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
42PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
43
44EXTRA_OECONF = " \
45 --enable-crypto-auth \
46 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
47 --without-libmetalink \
48 --without-libpsl \
49 --without-nghttp2 \
50"
51
52do_install_append() {
53 oe_multilib_header curl/curlbuild.h
54}
55
56do_install_append_class-target() {
57 # cleanup buildpaths from curl-config
58 sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/curl-config
59}
60
61PACKAGES =+ "lib${BPN}"
62
63FILES_lib${BPN} = "${libdir}/lib*.so.*"
64RRECOMMENDS_lib${BPN} += "ca-certificates"
65
66FILES_${PN} += "${datadir}/zsh"
67
68BBCLASSEXTEND = "native nativesdk"