diff options
Diffstat (limited to 'meta/recipes-support/curl/curl_7.51.0.bb')
-rw-r--r-- | meta/recipes-support/curl/curl_7.51.0.bb | 71 |
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.51.0.bb b/meta/recipes-support/curl/curl_7.51.0.bb new file mode 100644 index 0000000000..e1a996bbeb --- /dev/null +++ b/meta/recipes-support/curl/curl_7.51.0.bb | |||
@@ -0,0 +1,71 @@ | |||
1 | SUMMARY = "Command line tool and library for client-side URL transfers" | ||
2 | HOMEPAGE = "http://curl.haxx.se/" | ||
3 | BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker" | ||
4 | SECTION = "console/network" | ||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;beginline=8;md5=3a34942f4ae3fbf1a303160714e664ac" | ||
7 | |||
8 | SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \ | ||
9 | file://0001-replace-krb5-config-with-pkg-config.patch \ | ||
10 | " | ||
11 | |||
12 | # curl likes to set -g0 in CFLAGS, so we stop it | ||
13 | # from mucking around with debug options | ||
14 | # | ||
15 | SRC_URI += " file://configure_ac.patch" | ||
16 | |||
17 | SRC_URI[md5sum] = "09a7c5769a7eae676d5e2c86d51f167e" | ||
18 | SRC_URI[sha256sum] = "7f8240048907e5030f67be0a6129bc4b333783b9cca1391026d700835a788dde" | ||
19 | |||
20 | inherit autotools pkgconfig binconfig multilib_header | ||
21 | |||
22 | PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)} gnutls proxy zlib" | ||
23 | PACKAGECONFIG_class-native = "ipv6 proxy ssl zlib" | ||
24 | PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl zlib" | ||
25 | |||
26 | PACKAGECONFIG[dict] = "--enable-dict,--disable-dict," | ||
27 | PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls" | ||
28 | PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher," | ||
29 | PACKAGECONFIG[imap] = "--enable-imap,--disable-imap," | ||
30 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," | ||
31 | PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap," | ||
32 | PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps," | ||
33 | PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn" | ||
34 | PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2" | ||
35 | PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3," | ||
36 | PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy," | ||
37 | PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump" | ||
38 | PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp," | ||
39 | PACKAGECONFIG[smb] = "--enable-smb,--disable-smb," | ||
40 | PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp," | ||
41 | PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl" | ||
42 | PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet," | ||
43 | PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp," | ||
44 | PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib" | ||
45 | PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5" | ||
46 | |||
47 | EXTRA_OECONF = " \ | ||
48 | --enable-crypto-auth \ | ||
49 | --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \ | ||
50 | --without-libmetalink \ | ||
51 | --without-libpsl \ | ||
52 | --without-nghttp2 \ | ||
53 | " | ||
54 | |||
55 | do_install_append() { | ||
56 | oe_multilib_header curl/curlbuild.h | ||
57 | } | ||
58 | |||
59 | do_install_append_class-target() { | ||
60 | # cleanup buildpaths from curl-config | ||
61 | sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/curl-config | ||
62 | } | ||
63 | |||
64 | PACKAGES =+ "lib${BPN}" | ||
65 | |||
66 | FILES_lib${BPN} = "${libdir}/lib*.so.*" | ||
67 | RRECOMMENDS_lib${BPN} += "ca-certificates" | ||
68 | |||
69 | FILES_${PN} += "${datadir}/zsh" | ||
70 | |||
71 | BBCLASSEXTEND = "native nativesdk" | ||