summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.44.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.44.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.44.0.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.44.0.bb b/meta/recipes-support/curl/curl_7.44.0.bb
new file mode 100644
index 0000000000..b293303da3
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.44.0.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://pkgconfig_fix.patch \
10 "
11
12# curl likes to set -g0 in CFLAGS, so we stop it
13# from mucking around with debug options
14#
15SRC_URI += " file://configure_ac.patch"
16
17SRC_URI[md5sum] = "6b952ca00e5473b16a11f05f06aa8dae"
18SRC_URI[sha256sum] = "1e2541bae6582bb697c0fbae49e1d3e6fad5d05d5aa80dbd6f072e0a44341814"
19
20inherit autotools pkgconfig binconfig multilib_header
21
22PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)} gnutls zlib"
23PACKAGECONFIG_class-native = "ipv6 ssl zlib"
24PACKAGECONFIG_class-nativesdk = "ipv6 ssl zlib"
25
26PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
27PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
28PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
29PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
30PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
31PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
32PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
33
34EXTRA_OECONF = "--without-libidn \
35 --enable-crypto-auth \
36 --disable-ldap \
37 --disable-ldaps \
38 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
39"
40# see https://lists.yoctoproject.org/pipermail/poky/2013-December/009435.html
41# We should ideally drop ac_cv_sizeof_off_t from site files but until then
42EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'ac_cv_sizeof_off_t=8', '', d)}"
43
44do_install_append() {
45 oe_multilib_header curl/curlbuild.h
46}
47
48PACKAGES =+ "lib${BPN}"
49
50FILES_lib${BPN} = "${libdir}/lib*.so.*"
51RRECOMMENDS_lib${BPN} += "ca-certificates"
52
53BBCLASSEXTEND = "native nativesdk"