summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.37.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.37.1.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.37.1.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.37.1.bb b/meta/recipes-support/curl/curl_7.37.1.bb
new file mode 100644
index 0000000000..2f4da9706c
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.37.1.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://pkgconfig_fix.patch \
10 file://CVE-2014-3613.patch \
11 file://CVE-2014-3620.patch \
12 file://CVE-2015-3143.patch \
13 file://CVE-2015-3144.patch \
14 file://CVE-2015-3145.patch \
15 file://CVE-2014-3707.patch \
16 file://CVE-2014-8150.patch \
17 file://CVE-2015-3153.patch \
18"
19
20# curl likes to set -g0 in CFLAGS, so we stop it
21# from mucking around with debug options
22#
23SRC_URI += " file://configure_ac.patch"
24
25SRC_URI[md5sum] = "95c627abcf6494f5abe55effe7cd6a57"
26SRC_URI[sha256sum] = "c3ef3cd148f3778ddbefb344117d7829db60656efe1031f9e3065fc0faa25136"
27
28inherit autotools pkgconfig binconfig multilib_header
29
30PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)} gnutls zlib"
31PACKAGECONFIG_class-native = "ipv6 ssl zlib"
32PACKAGECONFIG_class-nativesdk = "ipv6 ssl zlib"
33
34PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
35PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
36PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
37PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
38PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
39PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
40
41EXTRA_OECONF = "--without-libidn \
42 --enable-crypto-auth \
43 --disable-ldap \
44 --disable-ldaps \
45 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
46"
47
48do_install_append() {
49 oe_multilib_header curl/curlbuild.h
50}
51
52PACKAGES =+ "lib${BPN} lib${BPN}-dev lib${BPN}-staticdev lib${BPN}-doc"
53
54FILES_lib${BPN} = "${libdir}/lib*.so.*"
55RRECOMMENDS_lib${BPN} += "ca-certificates"
56FILES_lib${BPN}-dev = "${includedir} \
57 ${libdir}/lib*.so \
58 ${libdir}/lib*.la \
59 ${libdir}/pkgconfig \
60 ${datadir}/aclocal \
61 ${bindir}/*-config"
62FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
63FILES_lib${BPN}-doc = "${mandir}/man3 \
64 ${mandir}/man1/curl-config.1"
65
66BBCLASSEXTEND = "native nativesdk"