summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.37.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.37.1.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.37.1.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.37.1.bb b/meta/recipes-support/curl/curl_7.37.1.bb
new file mode 100644
index 0000000000..14bdff75db
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.37.1.bb
@@ -0,0 +1,65 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8DEPENDS = "zlib gnutls"
9DEPENDS_class-native = "zlib-native openssl-native"
10DEPENDS_class-nativesdk = "nativesdk-zlib"
11
12SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
13 file://pkgconfig_fix.patch \
14"
15
16# curl likes to set -g0 in CFLAGS, so we stop it
17# from mucking around with debug options
18#
19SRC_URI += " file://configure_ac.patch"
20
21SRC_URI[md5sum] = "95c627abcf6494f5abe55effe7cd6a57"
22SRC_URI[sha256sum] = "c3ef3cd148f3778ddbefb344117d7829db60656efe1031f9e3065fc0faa25136"
23
24inherit autotools pkgconfig binconfig multilib_header
25
26PACKAGECONFIG ??= "gnutls ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
27PACKAGECONFIG_class-native = "ipv6 ssl"
28PACKAGECONFIG_class-nativesdk = "ipv6"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
30PACKAGECONFIG[ssl] = "--with-ssl, --without-ssl, ,"
31PACKAGECONFIG[gnutls] = "--with-gnutls=${STAGING_LIBDIR}/../, --without-gnutls, gnutls,"
32
33EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
34 --without-libssh2 \
35 --with-random=/dev/urandom \
36 --without-libidn \
37 --enable-crypto-auth \
38 --disable-ldap \
39 --disable-ldaps \
40 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
41 "
42
43do_configure_prepend() {
44 sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g ${S}/configure.ac
45}
46
47do_install_append() {
48 oe_multilib_header curl/curlbuild.h
49}
50
51PACKAGES =+ "lib${BPN} lib${BPN}-dev lib${BPN}-staticdev lib${BPN}-doc"
52
53FILES_lib${BPN} = "${libdir}/lib*.so.*"
54RRECOMMENDS_lib${BPN} += "ca-certificates"
55FILES_lib${BPN}-dev = "${includedir} \
56 ${libdir}/lib*.so \
57 ${libdir}/lib*.la \
58 ${libdir}/pkgconfig \
59 ${datadir}/aclocal \
60 ${bindir}/*-config"
61FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
62FILES_lib${BPN}-doc = "${mandir}/man3 \
63 ${mandir}/man1/curl-config.1"
64
65BBCLASSEXTEND = "native nativesdk"