summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.37.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.37.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.37.0.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.37.0.bb b/meta/recipes-support/curl/curl_7.37.0.bb
new file mode 100644
index 0000000000..1dc4ff3249
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.37.0.bb
@@ -0,0 +1,69 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8DEPENDS = "zlib gnutls"
9DEPENDS_class-native = "zlib-native openssl-native"
10DEPENDS_class-nativesdk = "nativesdk-zlib"
11
12SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
13 file://pkgconfig_fix.patch \
14"
15
16# curl likes to set -g0 in CFLAGS, so we stop it
17# from mucking around with debug options
18#
19SRC_URI += " file://configure_ac.patch"
20
21SRC_URI[md5sum] = "7dda0cc2e4136f78d5801ac347be696b"
22SRC_URI[sha256sum] = "24502492de3168b0556d8e1a06f14f7589e57b204917d602a572e14239b3e09e"
23
24inherit autotools pkgconfig binconfig multilib_header
25
26EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
27 --without-libssh2 \
28 --with-random=/dev/urandom \
29 --without-libidn \
30 --enable-crypto-auth \
31 --disable-ldap \
32 --disable-ldaps \
33 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
34 ${CURLGNUTLS} \
35 "
36
37CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
38CURLGNUTLS_class-native = "--without-gnutls --with-ssl"
39CURLGNUTLS_class-nativesdk = "--without-gnutls --without-ssl"
40
41PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
42PACKAGECONFIG_class-native = "ipv6"
43PACKAGECONFIG_class-nativesdk = "ipv6"
44
45PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
46
47do_configure_prepend() {
48 sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g ${S}/configure.ac
49}
50
51do_install_append() {
52 oe_multilib_header curl/curlbuild.h
53}
54
55PACKAGES =+ "lib${BPN} lib${BPN}-dev lib${BPN}-staticdev lib${BPN}-doc"
56
57FILES_lib${BPN} = "${libdir}/lib*.so.*"
58RRECOMMENDS_lib${BPN} += "ca-certificates"
59FILES_lib${BPN}-dev = "${includedir} \
60 ${libdir}/lib*.so \
61 ${libdir}/lib*.la \
62 ${libdir}/pkgconfig \
63 ${datadir}/aclocal \
64 ${bindir}/*-config"
65FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
66FILES_lib${BPN}-doc = "${mandir}/man3 \
67 ${mandir}/man1/curl-config.1"
68
69BBCLASSEXTEND = "native nativesdk"