diff options
Diffstat (limited to 'meta/recipes-support/curl/curl_7.33.0.bb')
-rw-r--r-- | meta/recipes-support/curl/curl_7.33.0.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.33.0.bb b/meta/recipes-support/curl/curl_7.33.0.bb new file mode 100644 index 0000000000..8539fec2c0 --- /dev/null +++ b/meta/recipes-support/curl/curl_7.33.0.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | DESCRIPTION = "Command line tool and library for client-side URL transfers." | ||
2 | HOMEPAGE = "http://curl.haxx.se/" | ||
3 | BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker" | ||
4 | SECTION = "console/network" | ||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac" | ||
7 | |||
8 | DEPENDS = "zlib gnutls" | ||
9 | DEPENDS_class-native = "zlib-native openssl-native" | ||
10 | DEPENDS_class-nativesdk = "nativesdk-zlib" | ||
11 | |||
12 | SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \ | ||
13 | file://pkgconfig_fix.patch \ | ||
14 | " | ||
15 | |||
16 | # curl likes to set -g0 in CFLAGS, so we stop it | ||
17 | # from mucking around with debug options | ||
18 | # | ||
19 | SRC_URI += " file://configure_ac.patch" | ||
20 | |||
21 | SRC_URI[md5sum] = "57409d6bf0bd97053b8378dbe0cadcef" | ||
22 | SRC_URI[sha256sum] = "0afde4cd949e2658eddc3cda675b19b165eea1af48ac5f3e1ec160792255d1b3" | ||
23 | |||
24 | inherit autotools pkgconfig binconfig | ||
25 | |||
26 | EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \ | ||
27 | --without-libssh2 \ | ||
28 | --with-random=/dev/urandom \ | ||
29 | --without-libidn \ | ||
30 | --enable-crypto-auth \ | ||
31 | --disable-ldap \ | ||
32 | --disable-ldaps \ | ||
33 | ${CURLGNUTLS} \ | ||
34 | " | ||
35 | |||
36 | CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl" | ||
37 | CURLGNUTLS_class-native = "--without-gnutls --with-ssl" | ||
38 | CURLGNUTLS_class-nativesdk = "--without-gnutls --without-ssl" | ||
39 | |||
40 | do_configure_prepend() { | ||
41 | sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g ${S}/configure.ac | ||
42 | } | ||
43 | |||
44 | PACKAGES =+ "${PN}-certs libcurl libcurl-dev libcurl-staticdev libcurl-doc" | ||
45 | |||
46 | FILES_${PN}-certs = "${datadir}/curl/curl-*" | ||
47 | PACKAGE_ARCH_${PN}-certs = "all" | ||
48 | |||
49 | FILES_lib${BPN} = "${libdir}/lib*.so.*" | ||
50 | RRECOMMENDS_lib${BPN} += "${PN}-certs" | ||
51 | FILES_lib${BPN}-dev = "${includedir} \ | ||
52 | ${libdir}/lib*.so \ | ||
53 | ${libdir}/lib*.la \ | ||
54 | ${libdir}/pkgconfig \ | ||
55 | ${datadir}/aclocal \ | ||
56 | ${bindir}/*-config" | ||
57 | FILES_lib${BPN}-staticdev = "${libdir}/lib*.a" | ||
58 | FILES_lib${BPN}-doc = "${mandir}/man3 \ | ||
59 | ${mandir}/man1/curl-config.1" | ||
60 | |||
61 | BBCLASSEXTEND = "native nativesdk" | ||