summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.31.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.31.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.31.0.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.31.0.bb b/meta/recipes-support/curl/curl_7.31.0.bb
new file mode 100644
index 0000000000..6d78ff2c47
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.31.0.bb
@@ -0,0 +1,61 @@
1DESCRIPTION = "Command line tool and library for client-side URL transfers."
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8DEPENDS = "zlib gnutls"
9DEPENDS_class-native = "zlib-native openssl-native"
10DEPENDS_class-nativesdk = "nativesdk-zlib"
11
12SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
13 file://pkgconfig_fix.patch \
14"
15
16# curl likes to set -g0 in CFLAGS, so we stop it
17# from mucking around with debug options
18#
19SRC_URI += " file://configure_ac.patch"
20
21SRC_URI[md5sum] = "b7bea20579ac2f696338ae03f2c19ba5"
22SRC_URI[sha256sum] = "a73b118eececff5de25111f35d1d0aafe1e71afdbb83082a8e44d847267e3e08"
23
24inherit autotools pkgconfig binconfig
25
26EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
27 --without-libssh2 \
28 --with-random=/dev/urandom \
29 --without-libidn \
30 --enable-crypto-auth \
31 --disable-ldap \
32 --disable-ldaps \
33 ${CURLGNUTLS} \
34 "
35
36CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
37CURLGNUTLS_class-native = "--without-gnutls --with-ssl"
38CURLGNUTLS_class-nativesdk = "--without-gnutls --without-ssl"
39
40do_configure_prepend() {
41 sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g ${S}/configure.ac
42}
43
44PACKAGES =+ "${PN}-certs libcurl libcurl-dev libcurl-staticdev libcurl-doc"
45
46FILES_${PN}-certs = "${datadir}/curl/curl-*"
47PACKAGE_ARCH_${PN}-certs = "all"
48
49FILES_lib${BPN} = "${libdir}/lib*.so.*"
50RRECOMMENDS_lib${BPN} += "${PN}-certs"
51FILES_lib${BPN}-dev = "${includedir} \
52 ${libdir}/lib*.so \
53 ${libdir}/lib*.la \
54 ${libdir}/pkgconfig \
55 ${datadir}/aclocal \
56 ${bindir}/*-config"
57FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
58FILES_lib${BPN}-doc = "${mandir}/man3 \
59 ${mandir}/man1/curl-config.1"
60
61BBCLASSEXTEND = "native nativesdk"