summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.29.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.29.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.29.0.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.29.0.bb b/meta/recipes-support/curl/curl_7.29.0.bb
new file mode 100644
index 0000000000..01ffeca56f
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.29.0.bb
@@ -0,0 +1,62 @@
1DESCRIPTION = "Command line tool and library for client-side URL transfers."
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8DEPENDS = "zlib gnutls"
9DEPENDS_class-native = "zlib-native openssl-native"
10DEPENDS_class-nativesdk = "nativesdk-zlib"
11PR = "r0"
12
13SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
14 file://pkgconfig_fix.patch \
15"
16
17# curl likes to set -g0 in CFLAGS, so we stop it
18# from mucking around with debug options
19#
20SRC_URI += " file://configure_ac.patch"
21
22SRC_URI[md5sum] = "fa5f37f38a8042020e292ce7ec5341ce"
23SRC_URI[sha256sum] = "9d78e8bac6fa101679ca82e72a24e55918c5d495d29acb1eff62610929d3832f"
24
25inherit autotools pkgconfig binconfig
26
27EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
28 --without-libssh2 \
29 --with-random=/dev/urandom \
30 --without-libidn \
31 --enable-crypto-auth \
32 --disable-ldap \
33 --disable-ldaps \
34 ${CURLGNUTLS} \
35 "
36
37CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
38CURLGNUTLS_class-native = "--without-gnutls --with-ssl"
39CURLGNUTLS_class-nativesdk = "--without-gnutls --without-ssl"
40
41do_configure_prepend() {
42 sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g ${S}/configure.ac
43}
44
45PACKAGES =+ "${PN}-certs libcurl libcurl-dev libcurl-staticdev libcurl-doc"
46
47FILES_${PN}-certs = "${datadir}/curl/curl-*"
48PACKAGE_ARCH_${PN}-certs = "all"
49
50FILES_lib${BPN} = "${libdir}/lib*.so.*"
51RRECOMMENDS_lib${BPN} += "${PN}-certs"
52FILES_lib${BPN}-dev = "${includedir} \
53 ${libdir}/lib*.so \
54 ${libdir}/lib*.la \
55 ${libdir}/pkgconfig \
56 ${datadir}/aclocal \
57 ${bindir}/*-config"
58FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
59FILES_lib${BPN}-doc = "${mandir}/man3 \
60 ${mandir}/man1/curl-config.1"
61
62BBCLASSEXTEND = "native nativesdk"