summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/createrepo/createrepo_0.4.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/createrepo/createrepo_0.4.11.bb')
-rw-r--r--meta/recipes-support/createrepo/createrepo_0.4.11.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/createrepo/createrepo_0.4.11.bb b/meta/recipes-support/createrepo/createrepo_0.4.11.bb
new file mode 100644
index 0000000000..49b45fc3b8
--- /dev/null
+++ b/meta/recipes-support/createrepo/createrepo_0.4.11.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Creates metadata indexes for RPM package repositories"
2HOMEPAGE = "http://createrepo.baseurl.org/"
3
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
6
7DEPENDS_class-native += "libxml2-native rpm-native"
8RDEPENDS_${PN}_class-target = "libxml2-python"
9
10PR = "r9"
11
12SRC_URI= "http://createrepo.baseurl.org/download/${BP}.tar.gz \
13 file://fix-native-install.patch \
14 file://python-scripts-should-use-interpreter-from-env.patch \
15 file://createrepo-rpm549.patch \
16 file://recommends.patch \
17 file://rpm-createsolvedb.py \
18 "
19
20SRC_URI[md5sum] = "3e9ccf4abcffe3f49af078c83611eda2"
21SRC_URI[sha256sum] = "a73ae11a0dcde8bde36d900bc3f7f8f1083ba752c70a5c61b72d1e1e7608f21b"
22
23BBCLASSEXTEND = "native"
24
25do_install () {
26 oe_runmake -e 'DESTDIR=${D}' install
27 install -m 0755 ${WORKDIR}/rpm-createsolvedb.py ${D}${bindir}/
28}
29
30# Wrap the python script since the native python is
31# ${bindir}/python-native/python, and the "#! /usr/bin/env python" can't
32# find it since it is not in PATH.
33do_install_append_class-native () {
34 # Not all the python scripts should be wrapped since some of
35 # them are modules (be imported).
36 for i in ${D}${datadir}/createrepo/genpkgmetadata.py \
37 ${D}${datadir}/createrepo/modifyrepo.py \
38 ${D}${bindir}/rpm-createsolvedb.py ; do
39 sed -i -e 's|^#!.*/usr/bin/env python|#! /usr/bin/env nativepython|' $i
40 done
41
42 create_wrapper ${D}/${bindir}/createrepo \
43 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
44 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
45 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
46}