summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/consolekit/consolekit_0.4.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/consolekit/consolekit_0.4.6.bb')
-rw-r--r--meta/recipes-support/consolekit/consolekit_0.4.6.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta/recipes-support/consolekit/consolekit_0.4.6.bb b/meta/recipes-support/consolekit/consolekit_0.4.6.bb
index 89f2d77b66..346bd60e4d 100644
--- a/meta/recipes-support/consolekit/consolekit_0.4.6.bb
+++ b/meta/recipes-support/consolekit/consolekit_0.4.6.bb
@@ -1,13 +1,15 @@
1SUMMARY = "Framework for defining and tracking users, login sessions, and seats" 1SUMMARY = "Framework for defining and tracking users, login sessions, and seats"
2DESCRIPTION = "It provides a mechanism for software to react to changes \
3of any of these items or of any of the metadata associated with them."
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ConsoleKit" 4HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ConsoleKit"
3BUGTRACKER = "https://bugs.freedesktop.org/buglist.cgi?query_format=specific&product=ConsoleKit" 5BUGTRACKER = "https://bugs.freedesktop.org/buglist.cgi?query_format=specific&product=ConsoleKit"
4 6
5LICENSE = "GPLv2+" 7LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ 8LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://src/main.c;endline=21;md5=0a994e09769780220163255d8f9071c3" 9 file://src/main.c;endline=21;md5=0a994e09769780220163255d8f9071c3"
8 10
9DEPENDS = "glib-2.0 glib-2.0-native dbus dbus-glib virtual/libx11" 11DEPENDS = "glib-2.0 glib-2.0-native dbus dbus-glib virtual/libx11"
10RDEPENDS_${PN} += "base-files" 12RDEPENDS:${PN} += "base-files"
11 13
12inherit autotools pkgconfig features_check 14inherit autotools pkgconfig features_check
13# depends on virtual/libx11 15# depends on virtual/libx11
@@ -27,17 +29,17 @@ PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd polkit', d
27 29
28PACKAGECONFIG[pam] = "--enable-pam-module --with-pam-module-dir=${base_libdir}/security,--disable-pam-module,libpam" 30PACKAGECONFIG[pam] = "--enable-pam-module --with-pam-module-dir=${base_libdir}/security,--disable-pam-module,libpam"
29PACKAGECONFIG[polkit] = "--with-polkit,--without-polkit,polkit" 31PACKAGECONFIG[polkit] = "--with-polkit,--without-polkit,polkit"
30PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--with-systemdsystemunitdir=" 32PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}/,--with-systemdsystemunitdir="
31 33
32FILES_${PN} += "${exec_prefix}/lib/ConsoleKit \ 34FILES:${PN} += "${exec_prefix}/lib/ConsoleKit \
33 ${libdir}/ConsoleKit ${systemd_unitdir} ${base_libdir} \ 35 ${libdir}/ConsoleKit ${systemd_unitdir} ${base_libdir} \
34 ${datadir}/dbus-1 ${datadir}/PolicyKit ${datadir}/polkit*" 36 ${datadir}/dbus-1 ${datadir}/PolicyKit ${datadir}/polkit*"
35 37
36PACKAGES =+ "pam-plugin-ck-connector" 38PACKAGES =+ "pam-plugin-ck-connector"
37FILES_pam-plugin-ck-connector += "${base_libdir}/security/*.so" 39FILES:pam-plugin-ck-connector += "${base_libdir}/security/*.so"
38RDEPENDS_pam-plugin-ck-connector += "${PN}" 40RDEPENDS:pam-plugin-ck-connector += "${PN}"
39 41
40do_install_append() { 42do_install:append() {
41 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 43 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
42 install -d ${D}${sysconfdir}/tmpfiles.d 44 install -d ${D}${sysconfdir}/tmpfiles.d
43 echo "d ${localstatedir}/log/ConsoleKit - - - -" \ 45 echo "d ${localstatedir}/log/ConsoleKit - - - -" \