summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ca-certificates/ca-certificates_20130610.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/ca-certificates/ca-certificates_20130610.bb')
-rw-r--r--meta/recipes-support/ca-certificates/ca-certificates_20130610.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-support/ca-certificates/ca-certificates_20130610.bb b/meta/recipes-support/ca-certificates/ca-certificates_20130610.bb
new file mode 100644
index 0000000000..0692ca2499
--- /dev/null
+++ b/meta/recipes-support/ca-certificates/ca-certificates_20130610.bb
@@ -0,0 +1,63 @@
1SUMMARY = "Common CA certificates"
2DESCRIPTION = "This package includes PEM files of CA certificates to allow \
3SSL-based applications to check for the authenticity of SSL connections."
4HOMEPAGE = "http://packages.debian.org/sid/ca-certificates"
5SECTION = "misc"
6LICENSE = "GPL-2.0+ & MPL-2.0"
7LIC_FILES_CHKSUM = "file://debian/copyright;md5=d8fc4ed45f01c31c87c9b496d4babcae"
8
9# This is needed to ensure we can run the postinst at image creation time
10DEPENDS = "ca-certificates-native"
11DEPENDS_class-native = ""
12
13# tag: debian/20130610
14SRCREV = "9f3c12784eaee1e2b005a23ce8b5c38e1e851404"
15
16SRC_URI = "git://anonscm.debian.org/collab-maint/ca-certificates.git \
17 file://0001-update-ca-certificates-remove-c-rehash.patch \
18 file://0002-update-ca-certificates-use-SYSROOT.patch \
19 file://default-sysroot.patch \
20 file://sbindir.patch"
21S = "${WORKDIR}/git"
22
23inherit allarch
24
25EXTRA_OEMAKE = "\
26 'CERTSDIR=${datadir}/ca-certificates' \
27 'SBINDIR=${sbindir}' \
28"
29
30do_install () {
31 install -d ${D}${datadir}/ca-certificates \
32 ${D}${sysconfdir}/ssl/certs \
33 ${D}${sysconfdir}/ca-certificates/update.d
34 oe_runmake 'DESTDIR=${D}' install
35
36 install -d ${D}${mandir}/man8
37 install -m 0644 sbin/update-ca-certificates.8 ${D}${mandir}/man8/
38
39 install -d ${D}${sysconfdir}
40 {
41 echo "# Lines starting with # will be ignored"
42 echo "# Lines starting with ! will remove certificate on next update"
43 echo "#"
44 find ${D}${datadir}/ca-certificates -type f -name '*.crt' | \
45 sed 's,^${D}${datadir}/ca-certificates/,,'
46 } >${D}${sysconfdir}/ca-certificates.conf
47}
48
49do_install_append_class-target () {
50 sed -i -e 's,/etc/,${sysconfdir}/,' \
51 -e 's,/usr/share/,${datadir}/,' \
52 -e 's,/usr/local,${prefix}/local,' \
53 ${D}${sbindir}/update-ca-certificates \
54 ${D}${mandir}/man8/update-ca-certificates.8
55}
56
57pkg_postinst_${PN} () {
58 SYSROOT="$D" update-ca-certificates
59}
60
61CONFFILES_${PN} += "${sysconfdir}/ca-certificates.conf"
62
63BBCLASSEXTEND += "native nativesdk"