summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/bmap-tools/bmap-tools_3.4.bb')
-rw-r--r--meta/recipes-support/bmap-tools/bmap-tools_3.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb b/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
new file mode 100644
index 0000000000..3f75fad44b
--- /dev/null
+++ b/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
2DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
3bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
4and copying files using the block map. The idea is that large file containing \
5unused blocks, like raw system image files, can be copied or flashed a lot \
6faster with bmaptool than with traditional tools like "dd" or "cp"."
7HOMEPAGE = "https://github.com/01org/bmap-tools"
8SECTION = "console/utils"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12SRC_URI = "git://github.com/01org/bmap-tools.git"
13SRCREV = "9dad724104df265442226972a1e310813f9ffcba"
14
15S = "${WORKDIR}/git"
16
17RDEPENDS_${PN} = "python-core python-compression python-mmap"
18
19inherit setuptools
20
21BBCLASSEXTEND = "native"
22
23do_install_append_class-native() {
24 sed -i -e 's|^#!.*/usr/bin/python-native/python|#! /usr/bin/env nativepython|' ${D}${bindir}/bmaptool
25}