summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/beecrypt/beecrypt_4.2.1.bb')
-rw-r--r--meta/recipes-support/beecrypt/beecrypt_4.2.1.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb b/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
new file mode 100644
index 0000000000..1e626f154c
--- /dev/null
+++ b/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
@@ -0,0 +1,48 @@
1# Beecrypt OE build file
2# Copyright (C) 2004-2005, Advanced Micro Devices, Inc. All Rights Reserved
3# Released under the MIT license (see packages/COPYING)
4
5SUMMARY = "A general-purpose cryptography library"
6HOMEPAGE = "http://sourceforge.net/projects/beecrypt"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
9 file://disable-icu-check.patch \
10 file://fix-security.patch \
11 file://fix-for-gcc-4.7.patch \
12 file://run-ptest \
13 file://beecrypt-enable-ptest-support.patch \
14 file://add-option-dev-dsp.patch \
15 "
16
17SRC_URI[md5sum] = "8441c014170823f2dff97e33df55af1e"
18SRC_URI[sha256sum] = "286f1f56080d1a6b1d024003a5fa2158f4ff82cae0c6829d3c476a4b5898c55d"
19
20LICENSE = "GPLv2 & LGPLv2.1"
21LIC_FILES_CHKSUM = "file://COPYING;md5=9894370afd5dfe7d02b8d14319e729a1 \
22 file://COPYING.LIB;md5=dcf3c825659e82539645da41a7908589 \
23 file://include/beecrypt/beecrypt.h;endline=20;md5=47a93eef539aac237eef86297a4d71c1"
24
25PR = "r3"
26
27inherit autotools multilib_header ptest
28acpaths=""
29
30do_install_append() {
31 oe_multilib_header beecrypt/gnu.h
32}
33
34EXTRA_OECONF = "--without-python --enable-shared --enable-static --disable-openmp --with-java=no"
35
36PACKAGECONFIG ??= ""
37PACKAGECONFIG[cplusplus] = "--with-cplusplus,--without-cplusplus,icu"
38
39FILES_${PN} = "${sysconfdir} ${libdir}/*.so.* ${libdir}/${BPN}/*.so.*"
40FILES_${PN}-dev += "${libdir}/${BPN}/*.so ${libdir}/${BPN}/*.la"
41FILES_${PN}-staticdev += "${libdir}/${BPN}/*.a"
42
43BBCLASSEXTEND = "native nativesdk"
44
45do_install_ptest () {
46 mkdir ${D}${PTEST_PATH}/tests
47 cp -r ${B}/tests/.libs/test* ${D}${PTEST_PATH}/tests
48}