diff options
Diffstat (limited to 'meta/recipes-support/bdwgc/bdwgc_7.6.0.bb')
-rw-r--r-- | meta/recipes-support/bdwgc/bdwgc_7.6.0.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb b/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb new file mode 100644 index 0000000000..55ea452068 --- /dev/null +++ b/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "A garbage collector for C and C++" | ||
2 | |||
3 | DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\ | ||
4 | used as a garbage collecting replacement for C malloc or C++ new. It allows\ | ||
5 | you to allocate memory basically as you normally would, without explicitly\ | ||
6 | deallocating memory that is no longer useful. The collector automatically\ | ||
7 | recycles memory when it determines that it can no longer be otherwise\ | ||
8 | accessed.\ | ||
9 | The collector is also used by a number of programming language\ | ||
10 | implementations that either use C as intermediate code, want to facilitate\ | ||
11 | easier interoperation with C libraries, or just prefer the simple collector\ | ||
12 | interface.\ | ||
13 | Alternatively, the garbage collector may be used as a leak detector for C\ | ||
14 | or C++ programs, though that is not its primary goal.\ | ||
15 | Empirically, this collector works with most unmodified C programs, simply\ | ||
16 | by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\ | ||
17 | calls, and removing free calls." | ||
18 | |||
19 | HOMEPAGE = "http://www.hboehm.info/gc/" | ||
20 | SECTION = "devel" | ||
21 | LICENSE = "MIT" | ||
22 | LIC_FILES_CHKSUM = "file://README.QUICK;md5=4f81f24ec69726c312487c2ac740e9e3" | ||
23 | |||
24 | SRCREV = "8ac1d84a40eb7a431fec1b8097e3f24b48fb23fa" | ||
25 | SRC_URI = "git://github.com/ivmai/bdwgc.git \ | ||
26 | file://0001-configure.ac-add-check-for-NO_GETCONTEXT-definition.patch \ | ||
27 | " | ||
28 | |||
29 | FILES_${PN}-doc = "${datadir}" | ||
30 | |||
31 | S = "${WORKDIR}/git" | ||
32 | |||
33 | ARM_INSTRUCTION_SET = "arm" | ||
34 | |||
35 | inherit autotools pkgconfig | ||
36 | |||
37 | # by default use external libatomic-ops | ||
38 | PACKAGECONFIG ??= "libatomic-ops" | ||
39 | PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops" | ||
40 | |||
41 | BBCLASSEXTEND = "native nativesdk" | ||