summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bdwgc/bdwgc_7.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/bdwgc/bdwgc_7.4.2.bb')
-rw-r--r--meta/recipes-support/bdwgc/bdwgc_7.4.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-support/bdwgc/bdwgc_7.4.2.bb b/meta/recipes-support/bdwgc/bdwgc_7.4.2.bb
new file mode 100644
index 0000000000..23ec95419c
--- /dev/null
+++ b/meta/recipes-support/bdwgc/bdwgc_7.4.2.bb
@@ -0,0 +1,41 @@
1SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hboehm.info/gc/"
20SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=55f5088f90a982fed7af9a4897047ef7"
23
24SRC_URI = "http://www.hboehm.info/gc/gc_source/gc-${PV}.tar.gz"
25
26SRC_URI[md5sum] = "12c05fd2811d989341d8c6d81f66af87"
27SRC_URI[sha256sum] = "63320ad7c45460e4a40e03f5aa4c6893783f21a16416c3282b994f933312afa2"
28FILES_${PN}-doc = "/usr/share"
29
30REAL_PV = "${@[d.getVar('PV',1)[:-1], d.getVar('PV',1)][(d.getVar('PV',1)[-1]).isdigit()]}"
31S = "${WORKDIR}/gc-${REAL_PV}"
32
33ARM_INSTRUCTION_SET = "arm"
34
35inherit autotools pkgconfig
36
37# by default use external libatomic-ops
38PACKAGECONFIG ??= "libatomic-ops"
39PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomics-ops"
40
41BBCLASSEXTEND = "native nativesdk"