summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bash-completion/bash-completion_2.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/bash-completion/bash-completion_2.11.bb')
-rw-r--r--meta/recipes-support/bash-completion/bash-completion_2.11.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta/recipes-support/bash-completion/bash-completion_2.11.bb b/meta/recipes-support/bash-completion/bash-completion_2.11.bb
deleted file mode 100644
index 19bc81619f..0000000000
--- a/meta/recipes-support/bash-completion/bash-completion_2.11.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1SUMMARY = "Programmable Completion for Bash 4"
2DESCRIPTION = "Collection of command line command completions for the Bash shell, \
3collection of helper functions to assist in creating new completions, \
4and set of facilities for loading completions automatically on demand, as well \
5as installing them."
6
7HOMEPAGE = "https://github.com/scop/bash-completion"
8BUGTRACKER = "https://github.com/scop/bash-completion/issues"
9
10LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
12
13SECTION = "console/utils"
14
15SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz"
16
17SRC_URI[md5sum] = "2514c6772d0de6254758b98c53f91861"
18SRC_URI[sha256sum] = "73a8894bad94dee83ab468fa09f628daffd567e8bef1a24277f1e9a0daf911ac"
19GITHUB_BASE_URI = "https://github.com/scop/bash-completion/releases"
20
21PARALLEL_MAKE = ""
22
23inherit autotools github-releases
24
25do_install:append() {
26 # compatdir
27 install -d ${D}${sysconfdir}/bash_completion.d/
28 echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
29
30}
31
32RDEPENDS:${PN} = "bash"
33
34# Some recipes are providing ${PN}-bash-completion packages
35PACKAGES =+ "${PN}-extra"
36FILES:${PN}-extra = "${datadir}/${BPN}/completions/ \
37 ${datadir}/${BPN}/helpers/"
38
39BBCLASSEXTEND = "nativesdk"