summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/argp-standalone/argp-standalone_1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/argp-standalone/argp-standalone_1.3.bb')
-rw-r--r--meta/recipes-support/argp-standalone/argp-standalone_1.3.bb32
1 files changed, 0 insertions, 32 deletions
diff --git a/meta/recipes-support/argp-standalone/argp-standalone_1.3.bb b/meta/recipes-support/argp-standalone/argp-standalone_1.3.bb
deleted file mode 100644
index 21bbcab3d3..0000000000
--- a/meta/recipes-support/argp-standalone/argp-standalone_1.3.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Glibc hierarchical argument parsing standalone library"
5HOMEPAGE = "http://www.lysator.liu.se/~nisse/misc/"
6LICENSE = "LGPL-2.1"
7LIC_FILES_CHKSUM = "file://argp.h;beginline=1;endline=20;md5=008b7e53dea6f9e1d9fdef0d9cf3184a"
8SECTION = "libs"
9
10SRC_URI = "http://www.lysator.liu.se/~nisse/misc/argp-standalone-${PV}.tar.gz \
11 file://0001-throw-in-funcdef.patch \
12 file://0002-isprint.patch \
13 file://out_of_tree_build.patch \
14 "
15SRC_URI[md5sum] = "720704bac078d067111b32444e24ba69"
16SRC_URI[sha256sum] = "dec79694da1319acd2238ce95df57f3680fea2482096e483323fddf3d818d8be"
17
18inherit autotools
19
20CFLAGS += "-fPIC -U__OPTIMIZE__"
21
22RDEPENDS_${PN}-dev = ""
23RDEPENDS_${PN}-staticdev = ""
24
25do_install() {
26 install -D -m 0644 ${B}/libargp.a ${D}${libdir}/libargp.a
27 install -D -m 0644 ${S}/argp.h ${D}${includedir}/argp.h
28}
29#
30# We will skip parsing for non-musl systems
31#
32COMPATIBLE_HOST = ".*-musl.*"