summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr_1.7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr_1.7.2.bb')
-rw-r--r--meta/recipes-support/apr/apr_1.7.2.bb135
1 files changed, 135 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr_1.7.2.bb b/meta/recipes-support/apr/apr_1.7.2.bb
new file mode 100644
index 0000000000..807dce21da
--- /dev/null
+++ b/meta/recipes-support/apr/apr_1.7.2.bb
@@ -0,0 +1,135 @@
1SUMMARY = "Apache Portable Runtime (APR) library"
2
3DESCRIPTION = "Create and maintain software libraries that provide a predictable \
4and consistent interface to underlying platform-specific implementations."
5
6HOMEPAGE = "http://apr.apache.org/"
7SECTION = "libs"
8DEPENDS = "util-linux"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4dfd4cd216828c8cae5de5a12f3844c8 \
12 file://include/apr_lib.h;endline=15;md5=823b3d1a7225df8f7b68a69c3c2b4c71"
13
14BBCLASSEXTEND = "native nativesdk"
15
16SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
17 file://run-ptest \
18 file://0002-apr-Remove-workdir-path-references-from-installed-ap.patch \
19 file://0004-Fix-packet-discards-HTTP-redirect.patch \
20 file://0005-configure.in-fix-LTFLAGS-to-make-it-work-with-ccache.patch \
21 file://0007-explicitly-link-libapr-against-phtread-to-make-gold-.patch \
22 file://libtoolize_check.patch \
23 file://0001-Add-option-to-disable-timed-dependant-tests.patch \
24 file://0001-configure-Remove-runtime-test-for-mmap-that-can-map-.patch \
25 "
26
27SRC_URI[sha256sum] = "75e77cc86776c030c0a5c408dfbd0bf2a0b75eed5351e52d5439fa1e5509a43e"
28
29inherit autotools-brokensep lib_package binconfig multilib_header ptest multilib_script
30
31OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
32
33# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
34CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
35# Enable largefile
36CACHED_CONFIGUREVARS += "apr_cv_use_lfs64=yes"
37# Additional AC_TRY_RUN tests which will need to be cached for cross compile
38CACHED_CONFIGUREVARS += "apr_cv_epoll=yes epoll_create1=yes apr_cv_sock_cloexec=yes \
39 ac_cv_struct_rlimit=yes \
40 ac_cv_func_sem_open=yes \
41 apr_cv_process_shared_works=yes \
42 apr_cv_mutex_robust_shared=yes \
43 "
44# Also suppress trying to use sctp.
45#
46CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
47
48# ac_cv_sizeof_struct_iovec is deduced using runtime check which will fail during cross-compile
49CACHED_CONFIGUREVARS += "${@['ac_cv_sizeof_struct_iovec=16','ac_cv_sizeof_struct_iovec=8'][d.getVar('SITEINFO_BITS') != '32']}"
50
51CACHED_CONFIGUREVARS += "ac_cv_file__dev_zero=yes"
52
53CACHED_CONFIGUREVARS:append:libc-musl = " ac_cv_strerror_r_rc_int=yes"
54PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
55PACKAGECONFIG:append:libc-musl = " xsi-strerror"
56PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
57PACKAGECONFIG[timed-tests] = "--enable-timed-tests,--disable-timed-tests,"
58PACKAGECONFIG[xsi-strerror] = "ac_cv_strerror_r_rc_int=yes,ac_cv_strerror_r_rc_int=no,"
59
60do_configure_prepend() {
61 # Avoid absolute paths for grep since it causes failures
62 # when using sstate between different hosts with different
63 # install paths for grep.
64 export GREP="grep"
65
66 cd ${S}
67 # The "2" means libtool version 2.
68 ./buildconf 2
69}
70
71MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/apr-1-config \
72 ${PN}-dev:${datadir}/build-1/apr_rules.mk"
73
74FILES_${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
75RDEPENDS_${PN}-dev += "bash"
76
77RDEPENDS_${PN}-ptest += "libgcc"
78
79#for some reason, build/libtool.m4 handled by buildconf still be overwritten
80#when autoconf, so handle it again.
81do_configure_append() {
82 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/libtool.m4
83 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/apr_rules.mk
84}
85
86do_install_append() {
87 oe_multilib_header apr.h
88 install -d ${D}${datadir}/apr
89}
90
91do_install_append_class-target() {
92 sed -i -e 's,${DEBUG_PREFIX_MAP},,g' \
93 -e 's,${STAGING_DIR_HOST},,g' ${D}${datadir}/build-1/apr_rules.mk
94 sed -i -e 's,${STAGING_DIR_HOST},,g' \
95 -e 's,APR_SOURCE_DIR=.*,APR_SOURCE_DIR=,g' \
96 -e 's,APR_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apr-1-config
97}
98
99SSTATE_SCAN_FILES += "apr_rules.mk libtool"
100
101SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
102
103apr_sysroot_preprocess () {
104 d=${SYSROOT_DESTDIR}${datadir}/apr
105 install -d $d/
106 cp ${S}/build/apr_rules.mk $d/
107 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
108 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
109 sed -i s,LIBTOOL=.*,LIBTOOL=${HOST_SYS}-libtool,g $d/apr_rules.mk
110 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
111 cp ${S}/build/mkdir.sh $d/
112 cp ${S}/build/make_exports.awk $d/
113 cp ${S}/build/make_var_export.awk $d/
114 cp ${S}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${datadir}/build-1/libtool
115}
116
117do_compile_ptest() {
118 cd ${S}/test
119 oe_runmake
120}
121
122do_install_ptest() {
123 t=${D}${PTEST_PATH}/test
124 mkdir -p $t/.libs
125 cp -r ${S}/test/data $t/
126 cp -r ${S}/test/.libs/*.so $t/.libs/
127 cp ${S}/test/proc_child $t/
128 cp ${S}/test/readchild $t/
129 cp ${S}/test/sockchild $t/
130 cp ${S}/test/sockperf $t/
131 cp ${S}/test/testall $t/
132 cp ${S}/test/tryread $t/
133}
134
135export CONFIG_SHELL="/bin/bash"