summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr_1.7.0.bb')
-rw-r--r--meta/recipes-support/apr/apr_1.7.0.bb125
1 files changed, 0 insertions, 125 deletions
diff --git a/meta/recipes-support/apr/apr_1.7.0.bb b/meta/recipes-support/apr/apr_1.7.0.bb
deleted file mode 100644
index f879e2864a..0000000000
--- a/meta/recipes-support/apr/apr_1.7.0.bb
+++ /dev/null
@@ -1,125 +0,0 @@
1SUMMARY = "Apache Portable Runtime (APR) library"
2DESCRIPTION = "The Apache Portable Runtime (APR) is a supporting library for the \
3Apache web server. It provides a set of APIs that map to the underlying \
4operating system (OS). Where the OS does not support a particular function, \
5APR will provide an emulation."
6HOMEPAGE = "http://apr.apache.org/"
7SECTION = "libs"
8DEPENDS = "util-linux"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4dfd4cd216828c8cae5de5a12f3844c8 \
12 file://include/apr_lib.h;endline=15;md5=823b3d1a7225df8f7b68a69c3c2b4c71"
13
14BBCLASSEXTEND = "native nativesdk"
15
16SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
17 file://run-ptest \
18 file://0002-apr-Remove-workdir-path-references-from-installed-ap.patch \
19 file://0003-Makefile.in-configure.in-support-cross-compiling.patch \
20 file://0004-Fix-packet-discards-HTTP-redirect.patch \
21 file://0005-configure.in-fix-LTFLAGS-to-make-it-work-with-ccache.patch \
22 file://0006-apr-fix-off_t-size-doesn-t-match-in-glibc-when-cross.patch \
23 file://0007-explicitly-link-libapr-against-phtread-to-make-gold-.patch \
24 file://libtoolize_check.patch \
25 file://0001-Add-option-to-disable-timed-dependant-tests.patch \
26 file://autoconf270.patch \
27 "
28
29SRC_URI[md5sum] = "7a14a83d664e87599ea25ff4432e48a7"
30SRC_URI[sha256sum] = "e2e148f0b2e99b8e5c6caa09f6d4fb4dd3e83f744aa72a952f94f5a14436f7ea"
31
32inherit autotools-brokensep lib_package binconfig multilib_header ptest multilib_script
33
34OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
35
36# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
37CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
38
39# Also suppress trying to use sctp.
40#
41CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
42
43CACHED_CONFIGUREVARS += "ac_cv_sizeof_struct_iovec=yes"
44CACHED_CONFIGUREVARS += "ac_cv_file__dev_zero=yes"
45
46PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
47PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
48PACKAGECONFIG[timed-tests] = "--enable-timed-tests,--disable-timed-tests,"
49
50do_configure_prepend() {
51 # Avoid absolute paths for grep since it causes failures
52 # when using sstate between different hosts with different
53 # install paths for grep.
54 export GREP="grep"
55
56 cd ${S}
57 # The "2" means libtool version 2.
58 ./buildconf 2
59}
60
61MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/apr-1-config \
62 ${PN}-dev:${datadir}/build-1/apr_rules.mk"
63
64FILES_${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
65RDEPENDS_${PN}-dev += "bash"
66
67RDEPENDS_${PN}-ptest += "libgcc"
68
69#for some reason, build/libtool.m4 handled by buildconf still be overwritten
70#when autoconf, so handle it again.
71do_configure_append() {
72 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/libtool.m4
73 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/apr_rules.mk
74}
75
76do_install_append() {
77 oe_multilib_header apr.h
78 install -d ${D}${datadir}/apr
79}
80
81do_install_append_class-target() {
82 sed -i -e 's,${DEBUG_PREFIX_MAP},,g' \
83 -e 's,${STAGING_DIR_HOST},,g' ${D}${datadir}/build-1/apr_rules.mk
84 sed -i -e 's,${STAGING_DIR_HOST},,g' \
85 -e 's,APR_SOURCE_DIR=.*,APR_SOURCE_DIR=,g' \
86 -e 's,APR_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apr-1-config
87}
88
89SSTATE_SCAN_FILES += "apr_rules.mk libtool"
90
91SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
92
93apr_sysroot_preprocess () {
94 d=${SYSROOT_DESTDIR}${datadir}/apr
95 install -d $d/
96 cp ${S}/build/apr_rules.mk $d/
97 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
98 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
99 sed -i s,LIBTOOL=.*,LIBTOOL=${HOST_SYS}-libtool,g $d/apr_rules.mk
100 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
101 cp ${S}/build/mkdir.sh $d/
102 cp ${S}/build/make_exports.awk $d/
103 cp ${S}/build/make_var_export.awk $d/
104 cp ${S}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${datadir}/build-1/libtool
105}
106
107do_compile_ptest() {
108 cd ${S}/test
109 oe_runmake
110}
111
112do_install_ptest() {
113 t=${D}${PTEST_PATH}/test
114 mkdir -p $t/.libs
115 cp -r ${S}/test/data $t/
116 cp -r ${S}/test/.libs/*.so $t/.libs/
117 cp ${S}/test/proc_child $t/
118 cp ${S}/test/readchild $t/
119 cp ${S}/test/sockchild $t/
120 cp ${S}/test/sockperf $t/
121 cp ${S}/test/testall $t/
122 cp ${S}/test/tryread $t/
123}
124
125export CONFIG_SHELL="/bin/bash"