diff options
Diffstat (limited to 'meta/recipes-support/apr/apr_1.7.0.bb')
-rw-r--r-- | meta/recipes-support/apr/apr_1.7.0.bb | 112 |
1 files changed, 112 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr_1.7.0.bb b/meta/recipes-support/apr/apr_1.7.0.bb new file mode 100644 index 0000000000..a58651d077 --- /dev/null +++ b/meta/recipes-support/apr/apr_1.7.0.bb | |||
@@ -0,0 +1,112 @@ | |||
1 | SUMMARY = "Apache Portable Runtime (APR) library" | ||
2 | HOMEPAGE = "http://apr.apache.org/" | ||
3 | SECTION = "libs" | ||
4 | DEPENDS = "util-linux" | ||
5 | |||
6 | LICENSE = "Apache-2.0" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4dfd4cd216828c8cae5de5a12f3844c8 \ | ||
8 | file://include/apr_lib.h;endline=15;md5=823b3d1a7225df8f7b68a69c3c2b4c71" | ||
9 | |||
10 | BBCLASSEXTEND = "native nativesdk" | ||
11 | |||
12 | SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \ | ||
13 | file://run-ptest \ | ||
14 | file://0001-build-buildcheck.sh-improve-libtool-detection.patch \ | ||
15 | file://0002-apr-Remove-workdir-path-references-from-installed-ap.patch \ | ||
16 | file://0003-Makefile.in-configure.in-support-cross-compiling.patch \ | ||
17 | file://0004-Fix-packet-discards-HTTP-redirect.patch \ | ||
18 | file://0005-configure.in-fix-LTFLAGS-to-make-it-work-with-ccache.patch \ | ||
19 | file://0006-apr-fix-off_t-size-doesn-t-match-in-glibc-when-cross.patch \ | ||
20 | file://0007-explicitly-link-libapr-against-phtread-to-make-gold-.patch \ | ||
21 | " | ||
22 | |||
23 | SRC_URI[md5sum] = "7a14a83d664e87599ea25ff4432e48a7" | ||
24 | SRC_URI[sha256sum] = "e2e148f0b2e99b8e5c6caa09f6d4fb4dd3e83f744aa72a952f94f5a14436f7ea" | ||
25 | |||
26 | inherit autotools-brokensep lib_package binconfig multilib_header ptest | ||
27 | |||
28 | OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'" | ||
29 | |||
30 | # Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928 | ||
31 | CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes" | ||
32 | |||
33 | # Also suppress trying to use sctp. | ||
34 | # | ||
35 | CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no" | ||
36 | |||
37 | CACHED_CONFIGUREVARS += "ac_cv_sizeof_struct_iovec=yes" | ||
38 | CACHED_CONFIGUREVARS += "ac_cv_file__dev_zero=yes" | ||
39 | |||
40 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" | ||
41 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," | ||
42 | |||
43 | do_configure_prepend() { | ||
44 | # Avoid absolute paths for grep since it causes failures | ||
45 | # when using sstate between different hosts with different | ||
46 | # install paths for grep. | ||
47 | export GREP="grep" | ||
48 | |||
49 | cd ${S} | ||
50 | libtool='${HOST_SYS}-libtool' ./buildconf | ||
51 | } | ||
52 | |||
53 | FILES_${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*" | ||
54 | RDEPENDS_${PN}-dev += "bash" | ||
55 | |||
56 | #for some reason, build/libtool.m4 handled by buildconf still be overwritten | ||
57 | #when autoconf, so handle it again. | ||
58 | do_configure_append() { | ||
59 | sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/libtool.m4 | ||
60 | sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/apr_rules.mk | ||
61 | } | ||
62 | |||
63 | do_install_append() { | ||
64 | oe_multilib_header apr.h | ||
65 | install -d ${D}${datadir}/apr | ||
66 | } | ||
67 | |||
68 | do_install_append_class-target() { | ||
69 | sed -i -e 's,${DEBUG_PREFIX_MAP},,g' \ | ||
70 | -e 's,${STAGING_DIR_HOST},,g' ${D}${datadir}/build-1/apr_rules.mk | ||
71 | sed -i -e 's,${STAGING_DIR_HOST},,g' \ | ||
72 | -e 's,APR_SOURCE_DIR=.*,APR_SOURCE_DIR=,g' \ | ||
73 | -e 's,APR_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apr-1-config | ||
74 | } | ||
75 | |||
76 | SSTATE_SCAN_FILES += "apr_rules.mk libtool" | ||
77 | |||
78 | SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess" | ||
79 | |||
80 | apr_sysroot_preprocess () { | ||
81 | d=${SYSROOT_DESTDIR}${datadir}/apr | ||
82 | install -d $d/ | ||
83 | cp ${S}/build/apr_rules.mk $d/ | ||
84 | sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk | ||
85 | sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk | ||
86 | sed -i s,LIBTOOL=.*,LIBTOOL=${HOST_SYS}-libtool,g $d/apr_rules.mk | ||
87 | sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk | ||
88 | cp ${S}/build/mkdir.sh $d/ | ||
89 | cp ${S}/build/make_exports.awk $d/ | ||
90 | cp ${S}/build/make_var_export.awk $d/ | ||
91 | cp ${S}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${datadir}/build-1/libtool | ||
92 | } | ||
93 | |||
94 | do_compile_ptest() { | ||
95 | cd ${S}/test | ||
96 | oe_runmake | ||
97 | } | ||
98 | |||
99 | do_install_ptest() { | ||
100 | t=${D}${PTEST_PATH}/test | ||
101 | mkdir -p $t/.libs | ||
102 | cp -r ${S}/test/data $t/ | ||
103 | cp -r ${S}/test/.libs/*.so $t/.libs/ | ||
104 | cp ${S}/test/proc_child $t/ | ||
105 | cp ${S}/test/readchild $t/ | ||
106 | cp ${S}/test/sockchild $t/ | ||
107 | cp ${S}/test/sockperf $t/ | ||
108 | cp ${S}/test/testall $t/ | ||
109 | cp ${S}/test/tryread $t/ | ||
110 | } | ||
111 | |||
112 | export CONFIG_SHELL="/bin/bash" | ||