summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr_1.7.0.bb')
-rw-r--r--meta/recipes-support/apr/apr_1.7.0.bb124
1 files changed, 0 insertions, 124 deletions
diff --git a/meta/recipes-support/apr/apr_1.7.0.bb b/meta/recipes-support/apr/apr_1.7.0.bb
deleted file mode 100644
index c9b9bf0f50..0000000000
--- a/meta/recipes-support/apr/apr_1.7.0.bb
+++ /dev/null
@@ -1,124 +0,0 @@
1SUMMARY = "Apache Portable Runtime (APR) library"
2DESCRIPTION = "The Apache Portable Runtime (APR) is a supporting library for the \
3Apache web server. It provides a set of APIs that map to the underlying \
4operating system (OS). Where the OS does not support a particular function, \
5APR will provide an emulation."
6HOMEPAGE = "http://apr.apache.org/"
7SECTION = "libs"
8DEPENDS = "util-linux"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4dfd4cd216828c8cae5de5a12f3844c8 \
12 file://include/apr_lib.h;endline=15;md5=823b3d1a7225df8f7b68a69c3c2b4c71"
13
14BBCLASSEXTEND = "native nativesdk"
15
16SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
17 file://run-ptest \
18 file://0002-apr-Remove-workdir-path-references-from-installed-ap.patch \
19 file://0003-Makefile.in-configure.in-support-cross-compiling.patch \
20 file://0004-Fix-packet-discards-HTTP-redirect.patch \
21 file://0005-configure.in-fix-LTFLAGS-to-make-it-work-with-ccache.patch \
22 file://0006-apr-fix-off_t-size-doesn-t-match-in-glibc-when-cross.patch \
23 file://0007-explicitly-link-libapr-against-phtread-to-make-gold-.patch \
24 file://libtoolize_check.patch \
25 file://0001-Add-option-to-disable-timed-dependant-tests.patch \
26 "
27
28SRC_URI[md5sum] = "7a14a83d664e87599ea25ff4432e48a7"
29SRC_URI[sha256sum] = "e2e148f0b2e99b8e5c6caa09f6d4fb4dd3e83f744aa72a952f94f5a14436f7ea"
30
31inherit autotools-brokensep lib_package binconfig multilib_header ptest multilib_script
32
33OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
34
35# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
36CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
37
38# Also suppress trying to use sctp.
39#
40CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
41
42CACHED_CONFIGUREVARS += "ac_cv_sizeof_struct_iovec=yes"
43CACHED_CONFIGUREVARS += "ac_cv_file__dev_zero=yes"
44
45PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
46PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
47PACKAGECONFIG[timed-tests] = "--enable-timed-tests,--disable-timed-tests,"
48
49do_configure_prepend() {
50 # Avoid absolute paths for grep since it causes failures
51 # when using sstate between different hosts with different
52 # install paths for grep.
53 export GREP="grep"
54
55 cd ${S}
56 # The "2" means libtool version 2.
57 ./buildconf 2
58}
59
60MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/apr-1-config \
61 ${PN}-dev:${datadir}/build-1/apr_rules.mk"
62
63FILES_${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
64RDEPENDS_${PN}-dev += "bash"
65
66RDEPENDS_${PN}-ptest += "libgcc"
67
68#for some reason, build/libtool.m4 handled by buildconf still be overwritten
69#when autoconf, so handle it again.
70do_configure_append() {
71 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/libtool.m4
72 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/apr_rules.mk
73}
74
75do_install_append() {
76 oe_multilib_header apr.h
77 install -d ${D}${datadir}/apr
78}
79
80do_install_append_class-target() {
81 sed -i -e 's,${DEBUG_PREFIX_MAP},,g' \
82 -e 's,${STAGING_DIR_HOST},,g' ${D}${datadir}/build-1/apr_rules.mk
83 sed -i -e 's,${STAGING_DIR_HOST},,g' \
84 -e 's,APR_SOURCE_DIR=.*,APR_SOURCE_DIR=,g' \
85 -e 's,APR_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apr-1-config
86}
87
88SSTATE_SCAN_FILES += "apr_rules.mk libtool"
89
90SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
91
92apr_sysroot_preprocess () {
93 d=${SYSROOT_DESTDIR}${datadir}/apr
94 install -d $d/
95 cp ${S}/build/apr_rules.mk $d/
96 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
97 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
98 sed -i s,LIBTOOL=.*,LIBTOOL=${HOST_SYS}-libtool,g $d/apr_rules.mk
99 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
100 cp ${S}/build/mkdir.sh $d/
101 cp ${S}/build/make_exports.awk $d/
102 cp ${S}/build/make_var_export.awk $d/
103 cp ${S}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${datadir}/build-1/libtool
104}
105
106do_compile_ptest() {
107 cd ${S}/test
108 oe_runmake
109}
110
111do_install_ptest() {
112 t=${D}${PTEST_PATH}/test
113 mkdir -p $t/.libs
114 cp -r ${S}/test/data $t/
115 cp -r ${S}/test/.libs/*.so $t/.libs/
116 cp ${S}/test/proc_child $t/
117 cp ${S}/test/readchild $t/
118 cp ${S}/test/sockchild $t/
119 cp ${S}/test/sockperf $t/
120 cp ${S}/test/testall $t/
121 cp ${S}/test/tryread $t/
122}
123
124export CONFIG_SHELL="/bin/bash"