summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr_1.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr_1.5.1.bb')
-rw-r--r--meta/recipes-support/apr/apr_1.5.1.bb95
1 files changed, 95 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr_1.5.1.bb b/meta/recipes-support/apr/apr_1.5.1.bb
new file mode 100644
index 0000000000..a27b2338d1
--- /dev/null
+++ b/meta/recipes-support/apr/apr_1.5.1.bb
@@ -0,0 +1,95 @@
1SUMMARY = "Apache Portable Runtime (APR) library"
2HOMEPAGE = "http://apr.apache.org/"
3SECTION = "libs"
4DEPENDS = "util-linux"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=4dfd4cd216828c8cae5de5a12f3844c8 \
8 file://include/apr_lib.h;endline=17;md5=ee42fa7575dc40580a9e01c1b75fae96"
9
10BBCLASSEXTEND = "native"
11
12SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
13 file://configure_fixes.patch \
14 file://cleanup.patch \
15 file://configfix.patch \
16 file://run-ptest \
17 file://upgrade-and-fix-1.5.1.patch \
18"
19
20SRC_URI[md5sum] = "5486180ec5a23efb5cae6d4292b300ab"
21SRC_URI[sha256sum] = "e94abe431d4da48425fcccdb27b469bd0f8151488f82e5630a56f26590e198ac"
22
23inherit autotools-brokensep lib_package binconfig multilib_header ptest
24
25OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
26
27# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
28CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
29
30# Also suppress trying to use sctp.
31#
32CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
33
34do_configure_prepend() {
35 # Avoid absolute paths for grep since it causes failures
36 # when using sstate between different hosts with different
37 # install paths for grep.
38 export GREP="grep"
39
40 cd ${S}
41 ./buildconf
42}
43
44FILES_${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
45RDEPENDS_${PN}-dev += "bash"
46
47#for some reason, build/libtool.m4 handled by buildconf still be overwritten
48#when autoconf, so handle it again.
49do_configure_append() {
50 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/libtool.m4
51 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/apr_rules.mk
52}
53
54do_install_append() {
55 oe_multilib_header apr.h
56 install -d ${D}${datadir}/apr
57 cp ${S}/${HOST_SYS}-libtool ${D}${datadir}/build-1/libtool
58}
59
60SSTATE_SCAN_FILES += "apr_rules.mk libtool"
61
62SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
63
64apr_sysroot_preprocess () {
65 d=${SYSROOT_DESTDIR}${datadir}/apr
66 install -d $d/
67 cp ${S}/build/apr_rules.mk $d/
68 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
69 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
70 sed -i s,LIBTOOL=.*,LIBTOOL=${HOST_SYS}-libtool,g $d/apr_rules.mk
71 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
72 cp ${S}/build/mkdir.sh $d/
73 cp ${S}/build/make_exports.awk $d/
74 cp ${S}/build/make_var_export.awk $d/
75}
76
77do_compile_ptest() {
78 cd ${S}/test
79 oe_runmake
80}
81
82do_install_ptest() {
83 t=${D}${PTEST_PATH}/test
84 mkdir -p $t/.libs
85 cp -r ${S}/test/data $t/
86 cp -r ${S}/test/.libs/*.so $t/.libs/
87 cp ${S}/test/proc_child $t/
88 cp ${S}/test/readchild $t/
89 cp ${S}/test/sockchild $t/
90 cp ${S}/test/sockperf $t/
91 cp ${S}/test/testall $t/
92 cp ${S}/test/tryread $t/
93}
94
95export CONFIG_SHELL="/bin/bash"