summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr_1.4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr_1.4.8.bb')
-rw-r--r--meta/recipes-support/apr/apr_1.4.8.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr_1.4.8.bb b/meta/recipes-support/apr/apr_1.4.8.bb
new file mode 100644
index 0000000000..d834170315
--- /dev/null
+++ b/meta/recipes-support/apr/apr_1.4.8.bb
@@ -0,0 +1,62 @@
1DESCRIPTION = "Apache Portable Runtime (APR) library"
2HOMEPAGE = "http://apr.apache.org/"
3SECTION = "libs"
4DEPENDS = "util-linux"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=0c35ff3c4c83b89d2f076e315caac28b \
8 file://include/apr_lib.h;endline=17;md5=ee42fa7575dc40580a9e01c1b75fae96"
9
10BBCLASSEXTEND = "native"
11
12SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
13 file://configure_fixes.patch \
14 file://cleanup.patch \
15 file://configfix.patch"
16
17SRC_URI[md5sum] = "ce2ab01a0c3cdb71cf0a6326b8654f41"
18SRC_URI[sha256sum] = "61b8d2f8d321c6365ee3d71d0bb41f3a89c44da6124cc5b407a3b8319d660421"
19
20inherit autotools lib_package binconfig multilib_header
21
22OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
23
24# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
25CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
26
27do_configure_prepend() {
28 cd ${S}
29 ./buildconf
30}
31
32FILES_${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
33
34#for some reason, build/libtool.m4 handled by buildconf still be overwritten
35#when autoconf, so handle it again.
36do_configure_append() {
37 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/libtool.m4
38 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/apr_rules.mk
39}
40
41do_install_append() {
42 oe_multilib_header apr.h
43 install -d ${D}${datadir}/apr
44 cp ${S}/${HOST_SYS}-libtool ${D}${datadir}/build-1/libtool
45}
46
47SSTATE_SCAN_FILES += "apr_rules.mk libtool"
48
49SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
50
51apr_sysroot_preprocess () {
52 d=${SYSROOT_DESTDIR}${datadir}/apr
53 install -d $d/
54 cp ${S}/build/apr_rules.mk $d/
55 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
56 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
57 sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${HOST_SYS}-libtool,g $d/apr_rules.mk
58 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
59 cp ${S}/build/mkdir.sh $d/
60 cp ${S}/build/make_exports.awk $d/
61 cp ${S}/build/make_var_export.awk $d/
62}