summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr_1.4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr_1.4.5.bb')
-rw-r--r--meta/recipes-support/apr/apr_1.4.5.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr_1.4.5.bb b/meta/recipes-support/apr/apr_1.4.5.bb
new file mode 100644
index 0000000000..b65e0427da
--- /dev/null
+++ b/meta/recipes-support/apr/apr_1.4.5.bb
@@ -0,0 +1,55 @@
1DESCRIPTION = "Apache Portable Runtime (APR) library"
2HOMEPAGE = "http://apr.apache.org/"
3SECTION = "libs"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0c35ff3c4c83b89d2f076e315caac28b \
7 file://include/apr_lib.h;endline=17;md5=ee42fa7575dc40580a9e01c1b75fae96"
8
9PR = "r1"
10
11SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
12 file://configure_fixes.patch \
13 file://cleanup.patch \
14 file://configfix.patch"
15
16SRC_URI[md5sum] = "8b53f5a5669d0597f2da889a2f576eb6"
17SRC_URI[sha256sum] = "38c61cacb39be649411cdab212979c71ce29495549c249c2e9a1b0d12480c93e"
18
19inherit autotools lib_package binconfig multilib_header
20
21OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
22
23do_configure_prepend() {
24 cd ${S}
25 ./buildconf
26}
27
28FILES_${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
29
30#for some reason, build/libtool.m4 handled by buildconf still be overwritten
31#when autoconf, so handle it again.
32do_configure_append() {
33 cd ${S}
34 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' build/libtool.m4
35 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' build/apr_rules.mk
36}
37
38do_install_append() {
39 oe_multilib_header apr.h
40}
41
42SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
43
44apr_sysroot_preprocess () {
45 d=${SYSROOT_DESTDIR}${datadir}/apr
46 install -d $d/
47 cp ${S}/build/apr_rules.mk $d/
48 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
49 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
50 sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${TARGET_PREFIX}libtool,g $d/apr_rules.mk
51 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
52 cp ${S}/build/mkdir.sh $d/
53 cp ${S}/build/make_exports.awk $d/
54 cp ${S}/build/make_var_export.awk $d/
55}