summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr_1.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr_1.3.3.bb')
-rw-r--r--meta/recipes-support/apr/apr_1.3.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr_1.3.3.bb b/meta/recipes-support/apr/apr_1.3.3.bb
new file mode 100644
index 0000000000..a193a18a2e
--- /dev/null
+++ b/meta/recipes-support/apr/apr_1.3.3.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Apache Portable Runtime (APR) library"
2SECTION = "libs"
3LICENSE = "Apache License, Version 2.0"
4
5PR = "r5"
6
7SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
8 file://configure_fixes.patch;patch=1 \
9 file://cleanup.patch;patch=1 \
10 file://configfix.patch;patch=1"
11
12inherit autotools lib_package binconfig
13
14OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
15
16do_configure_prepend() {
17 cd ${S}
18 ./buildconf
19}
20
21SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
22
23apr_sysroot_preprocess () {
24 d=${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/apr
25 install -d $d/
26 cp ${S}/build/apr_rules.mk $d/
27 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
28 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
29 sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${TARGET_PREFIX}libtool,g $d/apr_rules.mk
30 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
31 cp ${S}/build/mkdir.sh $d/
32 cp ${S}/build/make_exports.awk $d/
33 cp ${S}/build/make_var_export.awk $d/
34}