diff options
Diffstat (limited to 'meta/recipes-support/apr/apr-util_1.5.3.bb')
-rw-r--r-- | meta/recipes-support/apr/apr-util_1.5.3.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.5.3.bb b/meta/recipes-support/apr/apr-util_1.5.3.bb new file mode 100644 index 0000000000..063a787396 --- /dev/null +++ b/meta/recipes-support/apr/apr-util_1.5.3.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | SUMMARY = "Apache Portable Runtime (APR) companion library" | ||
2 | HOMEPAGE = "http://apr.apache.org/" | ||
3 | SECTION = "libs" | ||
4 | DEPENDS = "apr expat gdbm" | ||
5 | |||
6 | BBCLASSEXTEND = "native" | ||
7 | |||
8 | LICENSE = "Apache-2.0" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=519e0a18e03f7c023070568c14b077bb \ | ||
10 | file://include/apu_version.h;endline=17;md5=806685a84e71f10c80144c48eb35df42" | ||
11 | |||
12 | SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.gz \ | ||
13 | file://configfix.patch \ | ||
14 | file://configure_fixes.patch \ | ||
15 | file://run-ptest \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[md5sum] = "71a11d037240b292f824ba1eb537b4e3" | ||
19 | SRC_URI[sha256sum] = "76db34cb508e346e3bf69347c29ed1500bf0b71bcc48d54271ad9d1c25703743" | ||
20 | |||
21 | EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ | ||
22 | --without-odbc \ | ||
23 | --without-pgsql \ | ||
24 | --with-dbm=gdbm \ | ||
25 | --with-gdbm=${STAGING_DIR_HOST}${prefix} \ | ||
26 | --without-sqlite2 \ | ||
27 | --without-sqlite3 \ | ||
28 | --with-expat=${STAGING_DIR_HOST}${prefix}" | ||
29 | |||
30 | |||
31 | inherit autotools-brokensep lib_package binconfig | ||
32 | |||
33 | OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'" | ||
34 | |||
35 | do_configure_append() { | ||
36 | if [ "${CLASSOVERRIDE}" = "class-target" ]; then | ||
37 | cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk | ||
38 | fi | ||
39 | } | ||
40 | do_configure_prepend_class-native() { | ||
41 | cp ${STAGING_DATADIR_NATIVE}/apr/apr_rules.mk ${S}/build/rules.mk | ||
42 | } | ||
43 | do_configure_append_class-native() { | ||
44 | sed -i "s#LIBTOOL=\$(SHELL) \$(apr_builddir)#LIBTOOL=\$(SHELL) ${STAGING_BINDIR_NATIVE}#" ${S}/build/rules.mk | ||
45 | # sometimes there isn't SHELL | ||
46 | sed -i "s#LIBTOOL=\$(apr_builddir)#LIBTOOL=${STAGING_BINDIR_NATIVE}#" ${S}/build/rules.mk | ||
47 | } | ||
48 | |||
49 | FILES_${PN} += "${libdir}/apr-util-1/apr_dbm_gdbm-1.so" | ||
50 | FILES_${PN}-dev += "${libdir}/aprutil.exp ${libdir}/apr-util-1/apr_dbm_gdbm.so* ${libdir}/apr-util-1/apr_dbm_gdbm.la" | ||
51 | FILES_${PN}-dbg += "${libdir}/apr-util-1/.debug/*" | ||
52 | FILES_${PN}-staticdev += "${libdir}/apr-util-1/apr_dbm_gdbm.a" | ||
53 | |||
54 | inherit ptest | ||
55 | |||
56 | do_compile_ptest() { | ||
57 | cd ${S}/test | ||
58 | oe_runmake | ||
59 | } | ||
60 | |||
61 | do_install_ptest() { | ||
62 | t=${D}${PTEST_PATH}/test | ||
63 | mkdir $t | ||
64 | for i in testall data; do \ | ||
65 | cp -r ${S}/test/$i $t; \ | ||
66 | done | ||
67 | } | ||