summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr-util_1.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr-util_1.5.2.bb')
-rw-r--r--meta/recipes-support/apr/apr-util_1.5.2.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.5.2.bb b/meta/recipes-support/apr/apr-util_1.5.2.bb
new file mode 100644
index 0000000000..ea0f7fbb64
--- /dev/null
+++ b/meta/recipes-support/apr/apr-util_1.5.2.bb
@@ -0,0 +1,50 @@
1DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2HOMEPAGE = "http://apr.apache.org/"
3SECTION = "libs"
4DEPENDS = "apr expat gdbm"
5
6BBCLASSEXTEND = "native"
7
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=519e0a18e03f7c023070568c14b077bb \
10 file://include/apu_version.h;endline=17;md5=806685a84e71f10c80144c48eb35df42"
11
12SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.gz \
13 file://configfix.patch \
14 file://configure_fixes.patch"
15
16SRC_URI[md5sum] = "eb682cfb8642babba427a4fb391b15e8"
17SRC_URI[sha256sum] = "a1ec5025373815795d2fa5bfac40c0984675feffc88e049be9a162c408c2f613"
18
19EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
20 --without-odbc \
21 --without-pgsql \
22 --with-dbm=gdbm \
23 --with-gdbm=${STAGING_DIR_HOST}${prefix} \
24 --without-sqlite2 \
25 --without-sqlite3 \
26 --with-expat=${STAGING_DIR_HOST}${prefix}"
27
28
29inherit autotools lib_package binconfig
30
31OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
32
33do_configure_append() {
34 if [ "${CLASSOVERRIDE}" = "class-target" ]; then
35 cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
36 fi
37}
38do_configure_prepend_class-native() {
39 cp ${STAGING_DATADIR_NATIVE}/apr/apr_rules.mk ${S}/build/rules.mk
40}
41do_configure_append_class-native() {
42 sed -i "s#LIBTOOL=\$(SHELL) \$(apr_builddir)#LIBTOOL=\$(SHELL) ${STAGING_BINDIR_NATIVE}#" ${S}/build/rules.mk
43 # sometimes there isn't SHELL
44 sed -i "s#LIBTOOL=\$(apr_builddir)#LIBTOOL=${STAGING_BINDIR_NATIVE}#" ${S}/build/rules.mk
45}
46
47FILES_${PN} += "${libdir}/apr-util-1/apr_dbm_gdbm-1.so"
48FILES_${PN}-dev += "${libdir}/aprutil.exp ${libdir}/apr-util-1/apr_dbm_gdbm.so* ${libdir}/apr-util-1/apr_dbm_gdbm.la"
49FILES_${PN}-dbg += "${libdir}/apr-util-1/.debug/*"
50FILES_${PN}-staticdev += "${libdir}/apr-util-1/apr_dbm_gdbm.a"