summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr-util_1.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr-util_1.5.1.bb')
-rw-r--r--meta/recipes-support/apr/apr-util_1.5.1.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.5.1.bb b/meta/recipes-support/apr/apr-util_1.5.1.bb
new file mode 100644
index 0000000000..e547fe018f
--- /dev/null
+++ b/meta/recipes-support/apr/apr-util_1.5.1.bb
@@ -0,0 +1,52 @@
1DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2HOMEPAGE = "http://apr.apache.org/"
3SECTION = "libs"
4DEPENDS = "apr expat gdbm"
5
6BBCLASSEXTEND = "native"
7
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=519e0a18e03f7c023070568c14b077bb \
10 file://include/apu_version.h;endline=17;md5=806685a84e71f10c80144c48eb35df42"
11
12PR = "r0"
13
14SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.gz \
15 file://configfix.patch \
16 file://configure_fixes.patch"
17
18SRC_URI[md5sum] = "490c2e26e2dc95fd0983ad71112ddac6"
19SRC_URI[sha256sum] = "0cf4e48d93ceb9a5e314f48fe127211b71d30234665587e2eaffbb4fc13d931d"
20
21EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
22 --without-odbc \
23 --without-pgsql \
24 --with-dbm=gdbm \
25 --with-gdbm=${STAGING_DIR_HOST}${prefix} \
26 --without-sqlite2 \
27 --without-sqlite3 \
28 --with-expat=${STAGING_DIR_HOST}${prefix}"
29
30
31inherit autotools lib_package binconfig
32
33OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
34
35do_configure_append() {
36 if [ "${CLASSOVERRIDE}" = "class-target" ]; then
37 cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
38 fi
39}
40do_configure_prepend_class-native() {
41 cp ${STAGING_DATADIR_NATIVE}/apr/apr_rules.mk ${S}/build/rules.mk
42}
43do_configure_append_class-native() {
44 sed -i "s#LIBTOOL=\$(SHELL) \$(apr_builddir)#LIBTOOL=\$(SHELL) ${STAGING_BINDIR_NATIVE}#" ${S}/build/rules.mk
45 # sometimes there isn't SHELL
46 sed -i "s#LIBTOOL=\$(apr_builddir)#LIBTOOL=${STAGING_BINDIR_NATIVE}#" ${S}/build/rules.mk
47}
48
49FILES_${PN} += "${libdir}/apr-util-1/apr_dbm_gdbm-1.so"
50FILES_${PN}-dev += "${libdir}/aprutil.exp ${libdir}/apr-util-1/apr_dbm_gdbm.so* ${libdir}/apr-util-1/apr_dbm_gdbm.la"
51FILES_${PN}-dbg += "${libdir}/apr-util-1/.debug/*"
52FILES_${PN}-staticdev += "${libdir}/apr-util-1/apr_dbm_gdbm.a"