summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr-util_1.3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr-util_1.3.4.bb')
-rw-r--r--meta/recipes-support/apr/apr-util_1.3.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.3.4.bb b/meta/recipes-support/apr/apr-util_1.3.4.bb
new file mode 100644
index 0000000000..2e608e8a5c
--- /dev/null
+++ b/meta/recipes-support/apr/apr-util_1.3.4.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2SECTION = "libs"
3DEPENDS = "apr expat gdbm"
4LICENSE = "Apache License, Version 2.0"
5
6PR = "r5"
7
8SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
9 file://configfix.patch;patch=1 \
10 file://configure_fixes.patch;patch=1"
11
12EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
13 --with-dbm=gdbm \
14 --with-gdbm=${STAGING_DIR_HOST}${prefix} \
15 --without-sqlite2 \
16 --without-sqlite3 \
17 --with-expat=${STAGING_DIR_HOST}${prefix}"
18
19
20inherit autotools lib_package binconfig
21
22OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
23
24do_configure_prepend() {
25 cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
26}
27