summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr-util_1.3.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr-util_1.3.10.bb')
-rw-r--r--meta/recipes-support/apr/apr-util_1.3.10.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.3.10.bb b/meta/recipes-support/apr/apr-util_1.3.10.bb
new file mode 100644
index 0000000000..930f757ffd
--- /dev/null
+++ b/meta/recipes-support/apr/apr-util_1.3.10.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2HOMEPAGE = "http://apr.apache.org/"
3SECTION = "libs"
4DEPENDS = "apr expat gdbm"
5
6LICENSE = "Apache License, Version 2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=519e0a18e03f7c023070568c14b077bb \
8 file://include/apu_version.h;endline=17;md5=806685a84e71f10c80144c48eb35df42"
9
10PR = "r0"
11
12SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
13 file://configfix.patch;patch=1 \
14 file://configure_fixes.patch;patch=1"
15
16SRC_URI[md5sum] = "82acd25cf3df8c72eba44eaee8b80c19"
17SRC_URI[sha256sum] = "7c37ac40b2351bfc23000fb6b7b54a67e0872255df315c82eb60c821bcef4b23"
18
19EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
20 --without-odbc \
21 --with-dbm=gdbm \
22 --with-gdbm=${STAGING_DIR_HOST}${prefix} \
23 --without-sqlite2 \
24 --without-sqlite3 \
25 --with-expat=${STAGING_DIR_HOST}${prefix}"
26
27
28inherit autotools lib_package binconfig
29
30OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
31
32do_configure_prepend() {
33 cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
34}
35