summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/wpebackend-fdo_1.14.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/wpebackend-fdo_1.14.2.bb')
-rw-r--r--meta/recipes-sato/webkit/wpebackend-fdo_1.14.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/wpebackend-fdo_1.14.2.bb b/meta/recipes-sato/webkit/wpebackend-fdo_1.14.2.bb
new file mode 100644
index 0000000000..b3d7b229c8
--- /dev/null
+++ b/meta/recipes-sato/webkit/wpebackend-fdo_1.14.2.bb
@@ -0,0 +1,24 @@
1SUMMARY = "WPE's backend based on a freedesktop.org stack."
2HOMEPAGE = "https://github.com/Igalia/WPEBackend-fdo"
3BUGTRACKER = "https://github.com/Igalia/WPEBackend-fdo/issues"
4
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1f62cef2e3645e3e74eb05fd389d7a66"
7DEPENDS = "glib-2.0 libxkbcommon wayland virtual/egl libwpe libepoxy"
8
9DEPENDS:append:class-target = " wayland-native"
10
11inherit meson features_check pkgconfig
12
13REQUIRED_DISTRO_FEATURES = "opengl"
14
15SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
16SRC_URI[sha256sum] = "93c9766ae9864eeaeaee2b0a74f22cbca08df42c1a1bdb55b086f2528e380d38"
17
18# Especially helps compiling with clang which enable this as error when
19# using c++11
20CXXFLAGS += "-Wno-c++11-narrowing"
21
22# This is a tweak of upstream-version-is-even needed because
23# ipstream directory contains tarballs for other components as well.
24UPSTREAM_CHECK_REGEX = "wpebackend-fdo-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar"