summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.34.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.34.0.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.34.0.bb161
1 files changed, 161 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.34.0.bb b/meta/recipes-sato/webkit/webkitgtk_2.34.0.bb
new file mode 100644
index 0000000000..25e1d422cc
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.34.0.bb
@@ -0,0 +1,161 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD-2-Clause & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
15 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
16 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
17 file://0001-Enable-THREADS_PREFER_PTHREAD_FLAG.patch \
18 file://include_xutil.patch \
19 file://reduce-memory-overheads.patch \
20 file://musl-lower-stack-usage.patch \
21 file://0001-ANGLE-do-not-enable-SSE-on-x86.patch \
22 "
23
24SRC_URI[sha256sum] = "880c8ee626f67019f67557ca09e59a23ecf245e60f6173215f1a8823cb09af34"
25
26inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc
27
28ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
29REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
30
31CVE_PRODUCT = "webkitgtk webkitgtk\+"
32
33DEPENDS = " \
34 ruby-native \
35 cairo \
36 harfbuzz \
37 jpeg \
38 atk \
39 libwebp \
40 gtk+3 \
41 libsoup \
42 libxslt \
43 libtasn1 \
44 libnotify \
45 gstreamer1.0 \
46 gstreamer1.0-plugins-base \
47 "
48
49PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
50 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
51 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2 angle', d)} \
52 enchant \
53 libsecret \
54 "
55
56PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
57PACKAGECONFIG[angle] = "-DUSE_ANGLE_WEBGL=ON,-DUSE_ANGLE_WEBGL=OFF"
58PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
59PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
60PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
61PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
62PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
63PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/libgl"
64PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
65PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
66PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
67PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
68PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
69PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
70PACKAGECONFIG[lcms] = "-DUSE_LCMS=ON,-DUSE_LCMS=OFF,lcms"
71
72# webkitgtk is full of /usr/bin/env python, particular for generating docs
73do_configure[postfuncs] += "setup_python_link"
74setup_python_link() {
75 if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
76 ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
77 fi
78}
79
80EXTRA_OECMAKE = " \
81 -DPORT=GTK \
82 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
83 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
84 -DENABLE_MINIBROWSER=ON \
85 -DPYTHON_EXECUTABLE=`which python3` \
86 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
87 -DENABLE_GAMEPAD=OFF \
88 "
89
90# Javascript JIT is not supported on ARC
91EXTRA_OECMAKE:append:arc = " -DENABLE_JIT=OFF "
92# By default 25-bit "medium" calls are used on ARC
93# which is not enough for binaries larger than 32 MiB
94CFLAGS:append:arc = " -mlong-calls"
95CXXFLAGS:append:arc = " -mlong-calls"
96
97# Javascript JIT is not supported on powerpc
98EXTRA_OECMAKE:append:powerpc = " -DENABLE_JIT=OFF "
99EXTRA_OECMAKE:append:powerpc64 = " -DENABLE_JIT=OFF "
100
101# ARM JIT code does not build on ARMv4/5/6 anymore
102EXTRA_OECMAKE:append:armv5 = " -DENABLE_JIT=OFF "
103EXTRA_OECMAKE:append:armv6 = " -DENABLE_JIT=OFF "
104EXTRA_OECMAKE:append:armv4 = " -DENABLE_JIT=OFF "
105
106EXTRA_OECMAKE:append:mipsarch = " -DUSE_LD_GOLD=OFF "
107EXTRA_OECMAKE:append:powerpc = " -DUSE_LD_GOLD=OFF "
108
109# JIT and gold linker does not work on RISCV
110EXTRA_OECMAKE:append:riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
111EXTRA_OECMAKE:append:riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
112
113# JIT not supported on MIPS either
114EXTRA_OECMAKE:append:mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
115
116# JIT not supported on X32
117# An attempt was made to upstream JIT support for x32 in
118# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
119# unresolved due to limited X32 adoption.
120EXTRA_OECMAKE:append:x86-x32 = " -DENABLE_JIT=OFF "
121
122SECURITY_CFLAGS:remove:aarch64 = "-fpie"
123SECURITY_CFLAGS:append:aarch64 = " -fPIE"
124
125FILES:${PN} += "${libdir}/webkit2gtk-4.1/injected-bundle/libwebkit2gtkinjectedbundle.so"
126
127RRECOMMENDS:${PN} += "ca-certificates shared-mime-info"
128
129# http://errors.yoctoproject.org/Errors/Details/20370/
130ARM_INSTRUCTION_SET:armv4 = "arm"
131ARM_INSTRUCTION_SET:armv5 = "arm"
132ARM_INSTRUCTION_SET:armv6 = "arm"
133
134# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
135# https://bugs.webkit.org/show_bug.cgi?id=159880
136# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
137# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
138ARM_INSTRUCTION_SET:armv7a = "thumb"
139ARM_INSTRUCTION_SET:armv7r = "thumb"
140ARM_INSTRUCTION_SET:armv7ve = "thumb"
141
142# introspection inside qemu-arm hangs forever on musl/arm builds
143# therefore disable GI_DATA
144GI_DATA_ENABLED:libc-musl:armv7a = "False"
145GI_DATA_ENABLED:libc-musl:armv7ve = "False"
146
147# Can't be built with ccache
148CCACHE_DISABLE = "1"
149
150PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
151src_package_preprocess () {
152 # Trim build paths from comments in generated sources to ensure reproducibility
153 sed -i -e "s,${WORKDIR},,g" \
154 ${B}/JavaScriptCore/DerivedSources/*.h \
155 ${B}/JavaScriptCore/DerivedSources/yarr/*.h \
156 ${B}/JavaScriptCore/PrivateHeaders/JavaScriptCore/*.h \
157 ${B}/WebKit2Gtk/DerivedSources/webkit2/*.cpp \
158 ${B}/WebKit2Gtk/DerivedSources/webkit2/*.h
159
160}
161