summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.32.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.32.2.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.32.2.bb52
1 files changed, 26 insertions, 26 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.32.2.bb b/meta/recipes-sato/webkit/webkitgtk_2.32.2.bb
index 96b6cab49c..89b13314e5 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.32.2.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.32.2.bb
@@ -79,61 +79,61 @@ EXTRA_OECMAKE = " \
79 " 79 "
80 80
81# Javascript JIT is not supported on ARC 81# Javascript JIT is not supported on ARC
82EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF " 82EXTRA_OECMAKE:append:arc = " -DENABLE_JIT=OFF "
83# By default 25-bit "medium" calls are used on ARC 83# By default 25-bit "medium" calls are used on ARC
84# which is not enough for binaries larger than 32 MiB 84# which is not enough for binaries larger than 32 MiB
85CFLAGS_append_arc = " -mlong-calls" 85CFLAGS:append:arc = " -mlong-calls"
86CXXFLAGS_append_arc = " -mlong-calls" 86CXXFLAGS:append:arc = " -mlong-calls"
87 87
88# Javascript JIT is not supported on powerpc 88# Javascript JIT is not supported on powerpc
89EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF " 89EXTRA_OECMAKE:append:powerpc = " -DENABLE_JIT=OFF "
90EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF " 90EXTRA_OECMAKE:append:powerpc64 = " -DENABLE_JIT=OFF "
91 91
92# ARM JIT code does not build on ARMv4/5/6 anymore 92# ARM JIT code does not build on ARMv4/5/6 anymore
93EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF " 93EXTRA_OECMAKE:append:armv5 = " -DENABLE_JIT=OFF "
94EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF " 94EXTRA_OECMAKE:append:armv6 = " -DENABLE_JIT=OFF "
95EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF " 95EXTRA_OECMAKE:append:armv4 = " -DENABLE_JIT=OFF "
96 96
97EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF " 97EXTRA_OECMAKE:append:mipsarch = " -DUSE_LD_GOLD=OFF "
98EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF " 98EXTRA_OECMAKE:append:powerpc = " -DUSE_LD_GOLD=OFF "
99 99
100# JIT and gold linker does not work on RISCV 100# JIT and gold linker does not work on RISCV
101EXTRA_OECMAKE_append_riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF" 101EXTRA_OECMAKE:append:riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
102EXTRA_OECMAKE_append_riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF" 102EXTRA_OECMAKE:append:riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
103 103
104# JIT not supported on MIPS either 104# JIT not supported on MIPS either
105EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON " 105EXTRA_OECMAKE:append:mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
106 106
107# JIT not supported on X32 107# JIT not supported on X32
108# An attempt was made to upstream JIT support for x32 in 108# An attempt was made to upstream JIT support for x32 in
109# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as 109# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
110# unresolved due to limited X32 adoption. 110# unresolved due to limited X32 adoption.
111EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF " 111EXTRA_OECMAKE:append:x86-x32 = " -DENABLE_JIT=OFF "
112 112
113SECURITY_CFLAGS_remove_aarch64 = "-fpie" 113SECURITY_CFLAGS:remove:aarch64 = "-fpie"
114SECURITY_CFLAGS_append_aarch64 = " -fPIE" 114SECURITY_CFLAGS:append:aarch64 = " -fPIE"
115 115
116FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so" 116FILES:${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
117 117
118RRECOMMENDS_${PN} += "ca-certificates shared-mime-info" 118RRECOMMENDS:${PN} += "ca-certificates shared-mime-info"
119 119
120# http://errors.yoctoproject.org/Errors/Details/20370/ 120# http://errors.yoctoproject.org/Errors/Details/20370/
121ARM_INSTRUCTION_SET_armv4 = "arm" 121ARM_INSTRUCTION_SET:armv4 = "arm"
122ARM_INSTRUCTION_SET_armv5 = "arm" 122ARM_INSTRUCTION_SET:armv5 = "arm"
123ARM_INSTRUCTION_SET_armv6 = "arm" 123ARM_INSTRUCTION_SET:armv6 = "arm"
124 124
125# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474 125# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
126# https://bugs.webkit.org/show_bug.cgi?id=159880 126# https://bugs.webkit.org/show_bug.cgi?id=159880
127# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime. 127# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
128# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb). 128# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
129ARM_INSTRUCTION_SET_armv7a = "thumb" 129ARM_INSTRUCTION_SET:armv7a = "thumb"
130ARM_INSTRUCTION_SET_armv7r = "thumb" 130ARM_INSTRUCTION_SET:armv7r = "thumb"
131ARM_INSTRUCTION_SET_armv7ve = "thumb" 131ARM_INSTRUCTION_SET:armv7ve = "thumb"
132 132
133# introspection inside qemu-arm hangs forever on musl/arm builds 133# introspection inside qemu-arm hangs forever on musl/arm builds
134# therefore disable GI_DATA 134# therefore disable GI_DATA
135GI_DATA_ENABLED_libc-musl_armv7a = "False" 135GI_DATA_ENABLED:libc-musl:armv7a = "False"
136GI_DATA_ENABLED_libc-musl_armv7ve = "False" 136GI_DATA_ENABLED:libc-musl:armv7ve = "False"
137 137
138# Can't be built with ccache 138# Can't be built with ccache
139CCACHE_DISABLE = "1" 139CCACHE_DISABLE = "1"