summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.30.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.30.6.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.30.6.bb153
1 files changed, 153 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.30.6.bb b/meta/recipes-sato/webkit/webkitgtk_2.30.6.bb
new file mode 100644
index 0000000000..1fdba611ea
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.30.6.bb
@@ -0,0 +1,153 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
15 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
16 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
17 file://0001-Enable-THREADS_PREFER_PTHREAD_FLAG.patch \
18 file://0001-Fix-build-with-musl.patch \
19 file://include_xutil.patch \
20 file://reduce-memory-overheads.patch \
21 file://0001-Extend-atomics-check-to-include-1-byte-CAS-test.patch \
22 file://musl-lower-stack-usage.patch \
23 file://0001-MiniBrowser-Fix-reproduciblity.patch \
24 file://reproducibility.patch \
25 file://CVE-2021-42762.patch \
26 "
27
28SRC_URI[sha256sum] = "50736ec7a91770b5939d715196e5fe7209b93efcdeef425b24dc51fb8e9d7c1e"
29
30inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc
31
32ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
33REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
34
35CVE_PRODUCT = "webkitgtk webkitgtk\+"
36
37DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libgcrypt \
38 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
39 pango icu bison-native gawk intltool-native libwebp \
40 atk udev harfbuzz jpeg libpng librsvg libtheora libvorbis \
41 ruby-native libnotify gstreamer1.0-plugins-bad \
42 gettext-native glib-2.0 glib-2.0-native libtasn1 \
43 "
44
45PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
46 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
47 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
48 enchant \
49 libsecret \
50 "
51
52PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
53PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
54PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
55PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
56PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
57PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
58PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/libgl"
59PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
60PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
61PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
62PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
63PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
64PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
65
66# webkitgtk is full of /usr/bin/env python, particular for generating docs
67do_configure[postfuncs] += "setup_python_link"
68setup_python_link() {
69 if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
70 ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
71 fi
72}
73
74EXTRA_OECMAKE = " \
75 -DPORT=GTK \
76 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
77 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
78 -DENABLE_MINIBROWSER=ON \
79 -DPYTHON_EXECUTABLE=`which python3` \
80 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
81 "
82
83# Javascript JIT is not supported on ARC
84EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF "
85# By default 25-bit "medium" calls are used on ARC
86# which is not enough for binaries larger than 32 MiB
87CFLAGS_append_arc = " -mlong-calls"
88CXXFLAGS_append_arc = " -mlong-calls"
89
90# Javascript JIT is not supported on powerpc
91EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
92EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
93
94# ARM JIT code does not build on ARMv4/5/6 anymore
95EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
96EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
97EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
98
99EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
100EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
101
102# JIT and gold linker does not work on RISCV
103EXTRA_OECMAKE_append_riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
104EXTRA_OECMAKE_append_riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
105
106# JIT not supported on MIPS either
107EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
108
109# JIT not supported on X32
110# An attempt was made to upstream JIT support for x32 in
111# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
112# unresolved due to limited X32 adoption.
113EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF "
114
115SECURITY_CFLAGS_remove_aarch64 = "-fpie"
116SECURITY_CFLAGS_append_aarch64 = " -fPIE"
117
118FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
119
120RRECOMMENDS_${PN} += "ca-certificates shared-mime-info"
121
122# http://errors.yoctoproject.org/Errors/Details/20370/
123ARM_INSTRUCTION_SET_armv4 = "arm"
124ARM_INSTRUCTION_SET_armv5 = "arm"
125ARM_INSTRUCTION_SET_armv6 = "arm"
126
127# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
128# https://bugs.webkit.org/show_bug.cgi?id=159880
129# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
130# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
131ARM_INSTRUCTION_SET_armv7a = "thumb"
132ARM_INSTRUCTION_SET_armv7r = "thumb"
133ARM_INSTRUCTION_SET_armv7ve = "thumb"
134
135# introspection inside qemu-arm hangs forever on musl/arm builds
136# therefore disable GI_DATA
137GI_DATA_ENABLED_libc-musl_armv7a = "False"
138GI_DATA_ENABLED_libc-musl_armv7ve = "False"
139
140# Can't be built with ccache
141CCACHE_DISABLE = "1"
142
143PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
144src_package_preprocess () {
145 # Trim build paths from comments in generated sources to ensure reproducibility
146 sed -i -e "s,${WORKDIR},,g" \
147 ${B}/DerivedSources/webkit2gtk/webkit2/*.cpp \
148 ${B}/DerivedSources/ForwardingHeaders/JavaScriptCore/*.h \
149 ${B}/DerivedSources/JavaScriptCore/*.h \
150 ${B}/DerivedSources/JavaScriptCore/yarr/*.h \
151 ${B}/DerivedSources/MiniBrowser/*.c
152}
153