diff options
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.28.4.bb')
-rw-r--r-- | meta/recipes-sato/webkit/webkitgtk_2.28.4.bb | 132 |
1 files changed, 132 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb b/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb new file mode 100644 index 0000000000..8ebb3709a8 --- /dev/null +++ b/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb | |||
@@ -0,0 +1,132 @@ | |||
1 | SUMMARY = "WebKit web rendering engine for the GTK+ platform" | ||
2 | HOMEPAGE = "https://www.webkitgtk.org/" | ||
3 | BUGTRACKER = "https://bugs.webkit.org/" | ||
4 | |||
5 | LICENSE = "BSD & LGPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \ | ||
7 | file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \ | ||
8 | file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \ | ||
9 | file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \ | ||
10 | " | ||
11 | |||
12 | SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \ | ||
13 | file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \ | ||
14 | file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \ | ||
15 | file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \ | ||
16 | file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \ | ||
17 | file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \ | ||
18 | file://0001-Enable-THREADS_PREFER_PTHREAD_FLAG.patch \ | ||
19 | file://cross-compile.patch \ | ||
20 | file://0001-Fix-build-with-musl.patch \ | ||
21 | file://include_array.patch \ | ||
22 | file://0001-clang-11-fix-build-errors-due-to-WWc-11-narrowing.patch \ | ||
23 | " | ||
24 | SRC_URI[sha256sum] = "821952e8c9303ed752f1fb1d4283f612c25249d00d705d2b79c2db1bc49c9464" | ||
25 | |||
26 | inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc | ||
27 | |||
28 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" | ||
29 | REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}" | ||
30 | |||
31 | CVE_PRODUCT = "webkitgtk webkitgtk\+" | ||
32 | |||
33 | DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libgcrypt \ | ||
34 | gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \ | ||
35 | pango icu bison-native gawk intltool-native libwebp \ | ||
36 | atk udev harfbuzz jpeg libpng librsvg libtheora libvorbis \ | ||
37 | ruby-native libnotify gstreamer1.0-plugins-bad \ | ||
38 | gettext-native glib-2.0 glib-2.0-native libtasn1 \ | ||
39 | " | ||
40 | |||
41 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)} \ | ||
42 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \ | ||
43 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \ | ||
44 | enchant \ | ||
45 | libsecret \ | ||
46 | " | ||
47 | |||
48 | PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native" | ||
49 | PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt" | ||
50 | PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue" | ||
51 | PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2" | ||
52 | PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2" | ||
53 | PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl" | ||
54 | PACKAGECONFIG[opengl] = "-DENABLE_OPENGL=ON,-DENABLE_OPENGL=OFF,virtual/libgl" | ||
55 | PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret" | ||
56 | PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen" | ||
57 | PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2" | ||
58 | PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg" | ||
59 | |||
60 | # webkitgtk is full of /usr/bin/env python, particular for generating docs | ||
61 | do_configure[postfuncs] += "setup_python_link" | ||
62 | setup_python_link() { | ||
63 | if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then | ||
64 | ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python | ||
65 | fi | ||
66 | } | ||
67 | |||
68 | EXTRA_OECMAKE = " \ | ||
69 | -DPORT=GTK \ | ||
70 | -DCMAKE_BUILD_TYPE=Release \ | ||
71 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \ | ||
72 | ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \ | ||
73 | -DENABLE_MINIBROWSER=ON \ | ||
74 | -DPYTHON_EXECUTABLE=`which python3` \ | ||
75 | -DENABLE_BUBBLEWRAP_SANDBOX=OFF \ | ||
76 | " | ||
77 | |||
78 | # Javascript JIT is not supported on ARC | ||
79 | EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF " | ||
80 | # By default 25-bit "medium" calls are used on ARC | ||
81 | # which is not enough for binaries larger than 32 MiB | ||
82 | CFLAGS_append_arc = " -mlong-calls" | ||
83 | CXXFLAGS_append_arc = " -mlong-calls" | ||
84 | |||
85 | # Javascript JIT is not supported on powerpc | ||
86 | EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF " | ||
87 | EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF " | ||
88 | |||
89 | # ARM JIT code does not build on ARMv4/5/6 anymore | ||
90 | EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF " | ||
91 | EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF " | ||
92 | EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF " | ||
93 | |||
94 | EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF " | ||
95 | EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF " | ||
96 | |||
97 | # JIT not supported on MIPS either | ||
98 | EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON " | ||
99 | |||
100 | # JIT not supported on X32 | ||
101 | # An attempt was made to upstream JIT support for x32 in | ||
102 | # https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as | ||
103 | # unresolved due to limited X32 adoption. | ||
104 | EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF " | ||
105 | |||
106 | SECURITY_CFLAGS_remove_aarch64 = "-fpie" | ||
107 | SECURITY_CFLAGS_append_aarch64 = " -fPIE" | ||
108 | |||
109 | FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so" | ||
110 | |||
111 | RRECOMMENDS_${PN} += "ca-certificates shared-mime-info" | ||
112 | |||
113 | # http://errors.yoctoproject.org/Errors/Details/20370/ | ||
114 | ARM_INSTRUCTION_SET_armv4 = "arm" | ||
115 | ARM_INSTRUCTION_SET_armv5 = "arm" | ||
116 | ARM_INSTRUCTION_SET_armv6 = "arm" | ||
117 | |||
118 | # https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474 | ||
119 | # https://bugs.webkit.org/show_bug.cgi?id=159880 | ||
120 | # JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime. | ||
121 | # Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb). | ||
122 | ARM_INSTRUCTION_SET_armv7a = "thumb" | ||
123 | ARM_INSTRUCTION_SET_armv7r = "thumb" | ||
124 | ARM_INSTRUCTION_SET_armv7ve = "thumb" | ||
125 | |||
126 | # introspection inside qemu-arm hangs forever on musl/arm builds | ||
127 | # therefore disable GI_DATA | ||
128 | GI_DATA_ENABLED_libc-musl_armv7a = "False" | ||
129 | GI_DATA_ENABLED_libc-musl_armv7ve = "False" | ||
130 | |||
131 | # Can't be built with ccache | ||
132 | CCACHE_DISABLE = "1" | ||